Want ZECTEST for testing

I tried to get get zec for testnet to I can try some features but it’s not working
Can someone kindly send me some coins?

my address: tmVh5pr9PTEziPYsKDJ8h4sJsbdPejTTLZb

Thank you kindly.

How did you try? Are you mining or did you try https://faucet.testnet.z.cash?

I tried to get coins from the faucet, it seems like it did work but it’s not shown on the testnet explorer.

Now I stumble on a new problem… I managed to create a raw transaction, sign and send it seems like my address doesn’t show any balance on the explorer and cannot find the transaction. When checking it on zcash-cli it exists.

This explorer is broken https://explorer.testnet.z.cash/

https://chain.so/address/ZECTEST/tmVh5pr9PTEziPYsKDJ8h4sJsbdPejTTLZb (should show 8.9 ZECTEST, but says empty)

also this txid cannot be found 54e5bc363b29c40a8a2bcf180dcfce4e11d8bbcbdfd0d45c3d0e8776ea6460f8.

What version of zcashd are you running? You need to be on 2.0.0 to use that faucet as it is on the (new) Sapling testnet and it works correctly as I just tested it. The explorer hasn’t been updated for Sapling yet so yes you won’t be able to see your transaction there currently.

However if you are running a full node (v2.0.0 with -txindex) you can verify that that transaction does indeed exist:

zcash-cli getrawtransaction 54e5bc363b29c40a8a2bcf180dcfce4e11d8bbcbdfd0d45c3d0e8776ea6460f8



You can then use decoderawtransaction to get the details of that transaction but the relevant bit shows 3 ZEC (with 0.0001 for fees) was sent to tmFZAgUpWgiSY8GbRTmWZPht5qUn27SMhoz which I guess was from the faucet:

"vout": [
      "value": 2.99900000,
      "valueZat": 299900000,
      "n": 0,
      "scriptPubKey": {
        "asm": "OP_DUP OP_HASH160 40141ef9f6a417dd90d8a25fd3b748131821e645 OP_EQUALVERIFY OP_CHECKSIG",
        "hex": "76a91440141ef9f6a417dd90d8a25fd3b748131821e64588ac",
        "reqSigs": 1,
        "type": "pubkeyhash",
        "addresses": [

So if in doubt make sure you are on 2.0.0 and then try the faucet again.