Winzec 0 connection

Hi all.
I am mining zec and unpdate my wallet every couple of weeks.Since 16 June I have not been able to update my winzec wallet as there is 0 network connections. I have no idea what has gone wrong as it was working fine.
Anyone able to help me fix it please?

Hmmm WIndows Firewall blocking zcashd from getting out possibly? You have Symantec or another AV with a smart firewall that could be blocking it?

Thanks for the answer but apparently not. I left it open while at work for 12 hours. It has connections now but comes up with an error that says I need 1.1.0 or later for it to be compatible with the network upgrade . My version of winzec is 1.0.12

Just upgrade WinZEC. The latest release is 1.1.0 and is Overwinter compatible. You’ll have to upgrade to make a transaction.

I tried to but got the deamon is taking longer than expected error. I’m over winzec tbh. This is the third wallet in a row that hasn’t worked out of the box. I just transferred the private key to my phone with an android wallet and will most likely trade it in on an exchange.
It’s not profitable to mine and it doesn’t seem like zec is ever going to cater for windows users properly so I’ve decided to stop mining it anyway.