Z8 .conf file changes and connection issues?


#1

Hey everyone. I just spent the last couple of hours downloading, compiling and reinstalling version 8. I have basically compiled all of the test versions, but now for the first time, I'm having trouble connecting to the network. Have the parameters in the .zcash/zcash.conf file changed from
testnet=1
addnode=alphatestnet.z.cash
I saw someone saying something about connecting to atleastauthority?
I have rebooted the machine multiple times, but still it doesn't seem to connect to a single peer/host.
Any help would be much appreciated. Thanks


#2

Your config file is still good, I've seen a few others with this issue, it seems to be a problem syncing with the blockchain. Leastauthority is Zookos company, i believe that's where the servers are located.

I messaged the devs, but everyone has probably gone to bed, so we will see if they get back to us tomorrow


#3

Awesome thank you.. this is 20 characters...peace


#4

alphatestnet.z.cash is on EC2.

I've heard several reports of not being able to sync to the z8 chain; we'll try to figure out whether this is a global testnet issue or client misconfiguration (and fix either the testnet or the docs accordingly).


#5

I have been successfully mining using the prior releases. I am not making a connection with z8. I stopped and restarted the daemon this morning. Still no connection. Hope the info below helps.

Here is myzcash.conf:

testnet=1
addnode=alphatestnet.z.cash
rpcuser=username
rpcpassword=password
genproclimit=1
gen=1


lsof -i | grep zcashd
zcashd 2817 sthomas 9u IPv6 46450 0t0 TCP localhost:18232 (LISTEN)
zcashd 2817 sthomas 10u IPv4 46451 0t0 TCP localhost:18232 (LISTEN)
zcashd 2817 sthomas 12u IPv6 46452 0t0 TCP *:18233 (LISTEN)
zcashd 2817 sthomas 13u IPv4 46453 0t0 TCP *:18233 (LISTEN)


zcash-cli getinfo
{
"version" : 110200,
"protocolversion" : 170002,
"walletversion" : 60000,
"balance" : 2.88900000,
"blocks" : 207,
"timeoffset" : 0,
"connections" : 0,
"proxy" : "",
"difficulty" : 1.00000000,
"testnet" : true,
"keypoololdest" : 1470893700,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,
"errors" : "WARNING: check your network connection, 49 blocks received in the last 4 hours (96 expected)"
}


ping alphatestnet.z.cash
PING alphatestnet.z.cash (46.105.126.215) 56(84) bytes of data.

64 bytes from zcointest.leastauthority.com (46.105.126.215): icmp_seq=1 ttl=52 time=143 ms
64 bytes from zcointest.leastauthority.com (46.105.126.215): icmp_seq=2 ttl=52 time=144 ms
64 bytes from zcointest.leastauthority.com (46.105.126.215): icmp_seq=3 ttl=52 time=144 ms
64 bytes from zcointest.leastauthority.com (46.105.126.215): icmp_seq=4 ttl=52 time=142 ms
64 bytes from zcointest.leastauthority.com (46.105.126.215): icmp_seq=5 ttl=52 time=144 ms
64 bytes from zcointest.leastauthority.com (46.105.126.215): icmp_seq=6 ttl=52 time=144 ms


#6

Same here, both on Debian 7.10 that was mining with Z7 and on a completely fresh install of Debian 8.5.


#7

Yep, I'm in the same boat with one of my new machines :pensive:
Fresh install of Ubuntu Server 16,

shawn@Ubuntu903:~/zcash$ ./src/zcash-cli getinfo
    {
        "version" : 110200,
        "protocolversion" : 170002,
        "walletversion" : 60000,
        "balance" : 0.00000000,
        "blocks" : 26,
        "timeoffset" : 0,
        "connections" : 0,
        "proxy" : "",
        "difficulty" : 1.00000000,
        "testnet" : true,
        "keypoololdest" : 1470950115,
        "keypoolsize" : 101,
        "paytxfee" : 0.00000000,
        "relayfee" : 0.00005000,
        "errors" : "WARNING: check your network connection, 0 blocks received in the last 4 hours (96 expected)"
    }
    shawn@Ubuntu903:~/zcash$ ./src/zcash-cli stop
    Bitcoin server stopping
    shawn@Ubuntu903:~/zcash$ ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    64 bytes from 8.8.8.8: icmp_seq=1 ttl=43 time=54.5 ms
    64 bytes from 8.8.8.8: icmp_seq=2 ttl=43 time=64.3 ms
    64 bytes from 8.8.8.8: icmp_seq=3 ttl=43 time=63.5 ms
    64 bytes from 8.8.8.8: icmp_seq=4 ttl=43 time=67.6 ms
    64 bytes from 8.8.8.8: icmp_seq=5 ttl=43 time=64.5 ms
    64 bytes from 8.8.8.8: icmp_seq=6 ttl=43 time=88.5 ms
    64 bytes from 8.8.8.8: icmp_seq=7 ttl=43 time=74.2 ms
    64 bytes from 8.8.8.8: icmp_seq=8 ttl=43 time=57.1 ms
    64 bytes from 8.8.8.8: icmp_seq=9 ttl=43 time=54.7 ms
    64 bytes from 8.8.8.8: icmp_seq=10 ttl=43 time=66.8 ms
    64 bytes from 8.8.8.8: icmp_seq=11 ttl=43 time=58.5 ms
    64 bytes from 8.8.8.8: icmp_seq=12 ttl=43 time=54.3 ms
    64 bytes from 8.8.8.8: icmp_seq=13 ttl=43 time=76.5 ms
    64 bytes from 8.8.8.8: icmp_seq=14 ttl=43 time=75.6 ms
    ^C
    --- 8.8.8.8 ping statistics ---
    14 packets transmitted, 14 received, 0% packet loss, time 13007ms
    rtt min/avg/max/mdev = 54.388/65.820/88.537/9.718 ms

#8

I'm surprised that there's no support for discovering other network 'peers'. Why does alphatestnet.z.cash have to carry everyone?


#9

Because we have no idea which peers have right chain. Most of nodes are mining their own fork.


#10

The block number is 2815. I doubt anyone who has installed in the past ~48 hours is on it.


#11

The bootstrapping nodes for the P2P network aspects haven't been set up yet.


#12

Just wondering if there is any update regarding connection issues?

"version" : 110200,
"protocolversion" : 170002,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 15,
"timeoffset" : 0,
"connections" : 0,
"proxy" : "",
"difficulty" : 1.00000000,
"testnet" : true,
"keypoololdest" : 1470922661,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,
"errors" : "WARNING: check your network connection, 1 blocks received in the last 4 hours (96 expected)"

#13

What's the point of miners configured to create their own chains of empty blocks in the absence of a connection to the Zcash network?


#14

Folks, I tested on my 3 machines, you need to copy over the testnet3 folder to new machines you setup.

I upload my testnet3 folder here. Download it and overwrite your current folder then zcashd should be able to connect to peer leastauthority ip.

https://github.com/waterholeio/zcash.z8.testnet3

If you have not been able to connect to mine I assume you have 0 in wallet. But anyway if you do have some inside, then
back up you wallet.dat before overwrite the folder and mv it inside testnet3 later.


Cannot connect to (test) network
Thanks for getting me started
It seems the DoS Attack on testnet
I began mining. I have a question
#15

thank you very much, confirmed working. :+1:


#16

Using the supplied testnet3/peers.dat worked for me also. It seems that the fresh install failure, is related to peers.dat. The fresh install does not have ~/.zcash/testnet3 so it is created when starting the zcashd daemon. From the logs:

2016-08-12 16:36:17 ERROR: Read: Failed to open file /home/test/.zcash/testnet3/peers.dat
2016-08-12 16:36:17 Invalid or missing peers.dat; recreating
2016-08-12 16:36:17 Loaded 0 addresses from peers.dat 0ms
2016-08-12 16:36:17 dnsseed thread start
2016-08-12 16:36:17 Loading addresses from DNS seeds (could take a while)
2016-08-12 16:36:17 net thread start
2016-08-12 16:36:17 opencon thread start
2016-08-12 16:36:17 addcon thread start
2016-08-12 16:36:17 0 addresses found from DNS seeds
2016-08-12 16:36:17 dnsseed thread exit

Replacing the created peers.dat with a valid peers.dat solved the issue for me.


#17

Just copying over the .zcash/textnet3/peers.dat should be used. [ edit: maybe not. I could not get it to work with just a new peers.dat after a fresh install ]


#18

Thanks. I just updated so people can just download the peers file.


#19

I just tried copying over just peers.dat file after a new install and it didn't work.


#20

To clarify - once I did the fresh install, I started zcashd so the .zcash/testnet3 directory was built and then stopped the daemon. I moved peer.dat from testnet3 that was supplied previously into the new testnet3 directory. Started the daemon and connections were made.