Z8 .conf file changes and connection issues?

This happens because there is no checkpoint. (It's also the upstream Bitcoin Core behaviour when there is no checkpoint, I think, but obviously that hasn't been the case on the Bitcoin mainnet since early in its lifetime.) I'll file a ticket.

Did you try generate testnet3 first, then to copy overwrite?

So just replacing peers.dat seems to work? I re-insalled, then I ran zcashd before replacing it to see if it would not connect, which was probably a mistake. How do I "generate" testnet3 other than by re-installing?

I think you can just run zcashd after a fresh compilation. The testnet folder will be generated. Stop zcash then you can copy over

I tried replacing just peers.dat again, but it would not connect. So I saved the wallet.dat file, then deleted .zcash/testnet3, and copied over a good testnet3 and am overwriting the wallet.dat with the saved one. Maybe that will keep block collection separate. At least it's connecting.

Also, z7 verifying key from Amazon AWS is having trouble downloading, maybe due to others trying, so I'm going to try copying it over too (in .zcash-params) . The install bash file seems to say it will skip that step if it sees a good verifying.key already in place.

Can you copy and paste the error output when trying to download the z7 verifying key from Amazon AWS? It is strange that so many people are having problems given that S3 is supposed to be highly reliable and the key itself is only 1449 bytes in size. Thanks.

I'm sorry, I meant the proving key. 1 GB. That's only something I just now noticed. And it eventually downloaded so the only error I got was showing me its retry attempts, and for all I know my own network was the problem. But it worked.

All the problems in this thread are just that no new installs or upgrades (that's I'm aware of) are successful because they are not getting a connection to leastauthority:18232 (now showing 18233) and end up mining their own chain. str4d seem to be saying they can't find a node and waterhole found a work-around: copying over a working .zcash/testnet3. But in trying that on my own, all the blocks go to both the new wallets and the original wallet, so if you get someone else's testnet3, then also have your coins and the first one to send to themself I guess gets them.

Also, 2 people in this thread mentioned being on the same block number which indicates there was a fork.

Here's what I found in my log file that shows the first sign that there will not be a connection:

I used the files you made available and I believe my laptop is finally synced and mining. Thank you!

Am I on the right chain?

ub1@ub1:~/zcash$ lsof -i | grep zcashd
zcashd 5787 ub1 8u IPv6 132376 0t0 TCP ip6-localhost:18232 (LISTEN)
zcashd 5787 ub1 9u IPv4 132377 0t0 TCP localhost:18232 (LISTEN)
zcashd 5787 ub1 11u IPv6 132378 0t0 TCP *:18233 (LISTEN)
zcashd 5787 ub1 12u IPv4 132379 0t0 TCP *:18233 (LISTEN)
zcashd 5787 ub1 21u IPv4 107897 0t0 TCP 192.168.2.17:56072->zcointest.leastauthority.com:18233 (ESTABLISHED)
ub1@ub1:~/zcash$ ./src/zcash-cli getinfo
{
"version" : 110200,
"protocolversion" : 170002,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 4031,
"timeoffset" : 0,
"connections" : 1,
"proxy" : "",
"difficulty" : 127.87510671,
"testnet" : true,
"keypoololdest" : 1471138157,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,
"errors" : "This is a pre-release test build - use at your own risk - do not use for mining or merchant applications"
}

Hi Guys, i've got this error: "WARNING: check your network connection, 1 blocks received in the last 4 hours (96 expected)" as @waterhole suggested i've downloaded test3 folder and substituted.
Now with get info i have 3736 blocks...Good! but how to understand if it's mining?
My cpu consumption is at 0...So i think nothing it's happening...I'm right?

In few seconds after restarting zcash on getinfo i've got still the same problem "WARNING: check your network connection, 1 blocks received in the last 4 hours (96 expected)"... I'm on a VM could be some misconfiguration of the Internet connection? Is Something related with the DoS problem of few day ago ?

An other information: i'm still on V7, an upgrade needed?

Firstly you need to update to z8. Then make sure you have gen=1 in your .conf file to be mining. Zcash can be running if you don't have gen=1 set, you just won't be solving for blocks.

And based on that block # you are not connected to the correct chain. At this point I would consider waiting a few days until the network issues are resolved with the next version z9.

We think we have identified the bug (not a DoS attack) causing the connection issues:

Should be fixed in the z9 release :smile:

3 Likes

It seemed like it wasn't going to connect today so instead of copying over testnet, this worked:

~/zcash/src/zcash-cli addnode kirsche.oeste.de:18233 add

(they have a new list of nodes other than leastauthority and kirsche is one of them)

So it might pay to be more familiar with the old bitcoin API calls (as Shawn showed me before):

http://we.lovebitco.in/bitcoin-qt/command-reference/
https://en.bitcoin.it/wiki/Original_Bitcoin_client/API_calls_list

Just update:

Use z9, from scratch. it should work.

1 Like

I think maybe "from scratch" is a good idea. I tried the upgrade path and everything looks OK, except I'm not getting any blocks. Seems like a a big miner or two has jumped on and installed it correctly as the difficulty is 470. If everything's the same that would be about 100 PCs instead of 20 to 30 as it was most of the time in z7 and z8 (I think 60 was the high in z8, and 10 was the low). But I still should have had many blocks by now if I had installed it correctly.