Zcain explorer balance & zcash node balance different! Lost coins?

Hi, so flypool shows i have a transparent balance of https://explorer.zcha.in/accounts/t1JCTyzYgqufiATXM2HjfiobPKnNZxpXX5a 10.833 yet when I run z_gettotalbalance on my node it only shows a total balance of 0.82491623 and my node's block height is 21778 so it should be fully updated. Any ideas what could be going on? I'm worried i lost 10 ZEC.

Sounds like flypool has your earned coin in a different address? did you cash out to a different address? Or do you earn directly to a specific outside address?

I don't think flypool should have the coin in a different address; I've only been mining to this address. I'm just trying to take the coins that I've mined and send them to another t address.

I have a similar question regarding https://explorer.zcha.in/accounts/t1N87vfQ2XQremiLzYZayjq5Yhdnoqen9ew

I have this address locally via, zcash-cli listreceivedbyaddress 0 true. The address also shows in zcash-swing-wallet-ui. But, I have a zero balance here locally. Where is this 0.05586003 ZEC, I wonder? Does it take more than 11 hours and more than 280 confirmations for me to see it?

This is my first time trying to move ZEC from a service (suprnova) to my wallet. Did I do something wrong?

Actually I have the same issue... the explorer shows I have more than my
ledger wallet says I do though I trust my ledger wallet balance...

Strange. The explorer's balance is what I trust based on my hashrate. Would having an older client cause this problem perhaps?

My problem was that zcashd wasn't syncing properly. So, I ran zcashd -reindex to sync up and get the blocks with my transactions. Everything's working fine now.