Zcash4win BETA is out!

omg that is totally my bad, I was tired and had just been answering mac questions, my apologies

In a PowerShell window run the the command:

c:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

1 Like

thanks for the easy-to-use windows zcash wallet!

strange behavior: whenever I am mining zcash or other crypto and open zcash4win, i am no longer able to run my GPU at overclocked speeds. it just defaults to the base speed.

since this has an impact on how much Sol/s I earn, is there a way to work around this (maybe changing config settings)?

I've also notice this, got a little bit better when i didnt run it in GUI mode. But still drops a few sols/s.

Powershell.exe

c:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

I have no idea how it would interact with GPU, nothing in it that I know of would do that....maybe its some interaction with java (which the GUI is in) and the graphics drivers?

Im getting the exact same error and tried everything suggested above :frowning:

From command line the daemon wont even start

what're you seeing on the command line if its not starting up? and what's in end of the debug.log file when it doesn't?

017-06-03 03:29:47 Zcash version v1.0.8-1-a93dbc0 (2017-04-14 02:21:05 +0000)
2017-06-03 03:29:47 Using OpenSSL version OpenSSL 1.1.0d 26 Jan 2017
2017-06-03 03:29:47 Using BerkeleyDB version Berkeley DB 6.2.23: (March 28, 2016)
2017-06-03 03:29:47 Default data directory C:\Users*\AppData\Roaming\Zcash
2017-06-03 03:29:47 Using data directory C:\Users*\AppData\Roaming\Zcash
2017-06-03 03:29:47 Using config file C:\Users*\AppData\Roaming\Zcash\zcash.conf
2017-06-03 03:29:47 Using at most 125 connections (2048 file descriptors available)
2017-06-03 03:29:47 Using 4 threads for script verification
2017-06-03 03:29:47 scheduler thread start
2017-06-03 03:29:47 Loading verifying key from C:\Users*\AppData\Roaming\ZcashParams\sprout-verifying.key
2017-06-03 03:29:47 Loaded verifying key in 0.003003s seconds.
2017-06-03 03:29:47 HTTP: creating work queue of depth 16
2017-06-03 03:29:47 HTTP: starting 4 worker threads
2017-06-03 03:29:47 Using wallet wallet.dat
2017-06-03 03:29:47 init message: Verifying wallet...
2017-06-03 03:29:47 CDBEnv::Open: LogDir=C:\Users*\AppData\Roaming\Zcash\database ErrorFile=C:\Users*\AppData\Roaming\Zcash\db.log
2017-06-03 03:29:47 Bound to [::]:8233
2017-06-03 03:29:47 Bound to 0.0.0.0:8233
2017-06-03 03:29:47 Cache configuration:
2017-06-03 03:29:47 * Using 2.0MiB for block index database
2017-06-03 03:29:47 * Using 32.5MiB for chain state database
2017-06-03 03:29:47 * Using 65.5MiB for in-memory UTXO set
2017-06-03 03:29:47 init message: Loading block index...
2017-06-03 03:29:47 Opening LevelDB in C:\Users*\AppData\Roaming\Zcash\blocks\index
2017-06-03 03:29:47 Opened LevelDB successfully
2017-06-03 03:29:47 Opening LevelDB in C:\Users*\AppData\Roaming\Zcash\chainstate
2017-06-03 03:29:47 Opened LevelDB successfully
2017-06-03 03:29:49 LoadBlockIndexDB: last block file = 26
2017-06-03 03:29:49 LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=6097, size=118730890, heights=117532...123637, time=2017-05-20...2017-05-31)
2017-06-03 03:29:49 Checking all blk files are present...
2017-06-03 03:29:49 LoadBlockIndexDB: transaction index disabled
2017-06-03 03:29:49 Initializing databases...

Does it stop there, or keep going if you just wait? If it hasn't synced to 100%, its going to take a while

  program crashes there with the error above in the screen shot

So far I've tried
- Re downloading the proving key
- uninstall/reinstall of zcashwin
- tested firewall
- deleted old zcash.conf and re-ran first-time.bat
- deleted last block in case it was corrupt (restored it now)

ok, let's try launching it in a terminal window....start up PowerShell, and then run this command in it:

C:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

That'll startup zcashd in the PowerShell window in text mode, and it'll show block height, etc while it syncs.

Thanks for helping BTW :thumbsup:

It appears to not be doing anything, no new blocks being downloaded etc

that assertion failed message is not a good thing...what exact version of windows are you on? 7, 8, 10..... 32 or 64 bit

windows 10 64bit, though it was working fine for the last 2 weeks

I hate to recommend it, but have you tried re-syncing the blockchain all the way from scratch? (and if you do, run it from the command line as above until it gets caught up)

You can leave the *.log files and wallet.dat in place of course

ok doing a full re-sync now and it is running, cheers

Hi radius, one question please..
I have sent a 0.1 transaction from my z address holding 0.15 to another t addres..

In the transaction list, I can see the remaining 0.05 coming IN my z address. But I don't see the 0.1 going OUT to the T address.
However, the money arrived ok to the destination and in the blockchain explorer everything seems ok.

Is it normal behaviour of the wallet not showing the outgoing Z to T transactions?

Yes that's normal, nobody can see who sent it, not even you, when it's from
a z address.