Zcash4win BETA is out!

Wallet (wallet.dat) encryption is not (yet) supported by ZCash. When support becomes available, the GUI wallet will support it too...

@vaklinov,

Thank you for the answer; appreciated it. Is there a way to password protect the wallet?

“password protect” means to encrypt :wink:

I'm going to be working on doing that in the GUI code before/after it
launches zcashd, but that's obviously going to be a bit tricky to get
right, so it'll take a while

appreciate your hard work.

1 Like

You're very welcome!
Our donations page is here:
https://zcash.mercerweiss.com/index.html#Donations

@anon47418038
Zcash4win had been running fine up until today. I uninstalled it, got rid of everything and I am trying to start over. I am getting this error now. Earlier I was able to get it going and after stopping once got to around 65% of the blockchain.
Any suggestions as to how to get it going would be greatly appreciated.

I’d try starting the zcash daemon process by hand from the command line to let it do the initial sync of the blockchain.

That’s up above a few times but its quicker for me to type really quick than to search for :slight_smile:

Iin Terminal, run:

/Applications/zcash4mac.app/Contents/Java/zcashd -daemon=0 -showmetrics=1

It’ll show the current block height, and once that catches up to now, which you can check at https://zcha.in or https://insight.mercerweiss.com, you can launch zcash4mac. It’ll use the already running zcashd.

I am a bit confused. Your line seems to indicate mac and I am using zcash4win.

“in terminal” means on a command line or like this -

well that didn’t work so well :wink:
I was a bit confused (duh) by “mac” as I am using zcashfor win. I changed mac to win and still no joy.
I searched above and found the add nodes to .config so I added that
What am I doing wrong?

addnode=mainnet.z.cash
rpcuser=username
addnode=network.zcha.in
rpcpassword=password2163323261
daemon=1
showmetrics=0
gen=0

I added the addnode line
I am not sure what else I screwed up , but it is running currently …
fingers X :wink:

omg that is totally my bad, I was tired and had just been answering mac questions, my apologies

In a PowerShell window run the the command:

c:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

1 Like

thanks for the easy-to-use windows zcash wallet!

strange behavior: whenever I am mining zcash or other crypto and open zcash4win, i am no longer able to run my GPU at overclocked speeds. it just defaults to the base speed.

since this has an impact on how much Sol/s I earn, is there a way to work around this (maybe changing config settings)?

I've also notice this, got a little bit better when i didnt run it in GUI mode. But still drops a few sols/s.

Powershell.exe

c:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

I have no idea how it would interact with GPU, nothing in it that I know of would do that....maybe its some interaction with java (which the GUI is in) and the graphics drivers?

Im getting the exact same error and tried everything suggested above :frowning:

From command line the daemon wont even start

what're you seeing on the command line if its not starting up? and what's in end of the debug.log file when it doesn't?

017-06-03 03:29:47 Zcash version v1.0.8-1-a93dbc0 (2017-04-14 02:21:05 +0000)
2017-06-03 03:29:47 Using OpenSSL version OpenSSL 1.1.0d 26 Jan 2017
2017-06-03 03:29:47 Using BerkeleyDB version Berkeley DB 6.2.23: (March 28, 2016)
2017-06-03 03:29:47 Default data directory C:\Users*\AppData\Roaming\Zcash
2017-06-03 03:29:47 Using data directory C:\Users*\AppData\Roaming\Zcash
2017-06-03 03:29:47 Using config file C:\Users*\AppData\Roaming\Zcash\zcash.conf
2017-06-03 03:29:47 Using at most 125 connections (2048 file descriptors available)
2017-06-03 03:29:47 Using 4 threads for script verification
2017-06-03 03:29:47 scheduler thread start
2017-06-03 03:29:47 Loading verifying key from C:\Users*\AppData\Roaming\ZcashParams\sprout-verifying.key
2017-06-03 03:29:47 Loaded verifying key in 0.003003s seconds.
2017-06-03 03:29:47 HTTP: creating work queue of depth 16
2017-06-03 03:29:47 HTTP: starting 4 worker threads
2017-06-03 03:29:47 Using wallet wallet.dat
2017-06-03 03:29:47 init message: Verifying wallet...
2017-06-03 03:29:47 CDBEnv::Open: LogDir=C:\Users*\AppData\Roaming\Zcash\database ErrorFile=C:\Users*\AppData\Roaming\Zcash\db.log
2017-06-03 03:29:47 Bound to [::]:8233
2017-06-03 03:29:47 Bound to 0.0.0.0:8233
2017-06-03 03:29:47 Cache configuration:
2017-06-03 03:29:47 * Using 2.0MiB for block index database
2017-06-03 03:29:47 * Using 32.5MiB for chain state database
2017-06-03 03:29:47 * Using 65.5MiB for in-memory UTXO set
2017-06-03 03:29:47 init message: Loading block index...
2017-06-03 03:29:47 Opening LevelDB in C:\Users*\AppData\Roaming\Zcash\blocks\index
2017-06-03 03:29:47 Opened LevelDB successfully
2017-06-03 03:29:47 Opening LevelDB in C:\Users*\AppData\Roaming\Zcash\chainstate
2017-06-03 03:29:47 Opened LevelDB successfully
2017-06-03 03:29:49 LoadBlockIndexDB: last block file = 26
2017-06-03 03:29:49 LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=6097, size=118730890, heights=117532...123637, time=2017-05-20...2017-05-31)
2017-06-03 03:29:49 Checking all blk files are present...
2017-06-03 03:29:49 LoadBlockIndexDB: transaction index disabled
2017-06-03 03:29:49 Initializing databases...

Does it stop there, or keep going if you just wait? If it hasn't synced to 100%, its going to take a while