Zcash4win Stuck Activating Best Chain

Hi, I am running Windows 7, it was working perfectly then since last week it gets stuck on Activating Best Chain. Any Idea on how to solve this? Thanks

If just restarting it (and the machine) and then letting it sit a while doesn't fix it, you may need to try re-indexing. With zcash4win stopped, from the Start menu open PowerShell to get a command prompt. Then enter the following command:

C:\Program Files\zcash4win\app\zcashd.exe -reindex -showmetrics=1 -daemon=0
(NOTE: edited, I erroneously typed -daemon=1 earlier when it should be 0)

Which will startup the zcash server in the foreground and reindex your local copy of the blockchain. It'll take a WHILE, but you can see its progress, and when the block height matches that show at https://zcha.in or https://insight.mercerweiss.com (the two public block explorers), fire up zcash4win. It'll detect that zcashd is already running and won't try to launch a second instance of it.

Thanks for the reply I tried but I get this error:
"There is no RPC client functionality in zcashd. Use the zcash-cli utility instead"

can you please copy and paste the command you typed that gave you that error?

Please try to launch with PowerShell not cmd

Same error

you have a - floating off by itself that should be in front of the word daemon (and I'd omitted it in front of daemon)...and on top of that I had a brain fart above, it should be -daemon=0....so we both messed up...sorry :frowning:

The reindexing is working :slight_smile:
I'll try again when the block height matches

1 Like

great! sorry for the typos I didn't catch faster....the kids were distracting me!

It's working! Thanks a lot :slight_smile:

1 Like