ZCL Wallet Z address no balance

Hi all,

I have started mining ZCL a couple of days ago and I’m now wondering if I didn’t miss something because I see contradictory information. I don’t know if ZCL talks are ok here, let me know if not.

I have installed ZCL on ubuntu, I have created a Z and a T address and I’m pointing my rig to my T address. I’m using zclassic.miningspeed.com as mining pool.
So far, everything is ok, I see my balance increasing on Miningspeed but I don’t understand the difference between t and z address.

My T address has balance on the mining pool, my Z address has no balance while I thought both were somehow connected.

./src/zcash-cli z_listaddresses
I see my z address here

./src/zcash-cli getinfo
gives the following
{
“version”: 1001051,
“protocolversion”: 170002,
“walletversion”: 60000,
“balance”: 0.00000000,
“blocks”: 0,
“timeoffset”: 0,
“connections”: 0,
“proxy”: “”,
“difficulty”: 1,
“testnet”: false,
“keypoololdest”: 1514298407,
“keypoolsize”: 101,
“paytxfee”: 0.00000000,
“relayfee”: 0.00000100,
“errors”: “”
}

If I start zclassic to sync the blockchain, I see that everything there remain at 0 while I’m mining:

There must be something wrong or something I’m missing but I don’t know what Sad

thanks

small up, any idea?

I’d like to transfer my ZCL to my centralized account but sending from command line only seems to be working with Z address

I mined zclassic for one day, but I already changed back to zcash, because the difficulty is already very high now and I’m not sure about the future of zclassic (bitcoin private).
But I know a solution for your problem. Just change your config file:

addnode=104.207.149.241:8133
addnode=45.76.4.70:8133
addnode=68.234.31.67:8133
addnode=52.14.116.113:8133
addnode=136.243.50.159:8133
addnode=88.99.199.93:8133
addnode=13.91.45.250:8133
addnode=94.130.11.10:8133
addnode=37.187.167.145:8133
addnode=5.9.111.40:8133
addnode=120.27.230.83:8133
addnode=138.197.199.86:8133
addnode=52.53.125.97:8133
addnode=198.100.147.192:8133
addnode=79.98.144.29:8133
addnode=62.163.150.178:8133
addnode=94.177.229.186:8133
addnode=78.94.32.196:8133
addnode=78.94.32.194:8133
addnode=60.170.218.192:8133
addnode=151.80.96.105:8133
addnode=139.59.230.86:8133
addnode=45.32.233.113:8133
addnode=45.32.234.100:8133
addnode=87.103.195.162:8133
addnode=58.9.134.10:8133
addnode=206.255.161.228:8133
addnode=89.212.102.22:8133
addnode=79.164.95.176:8133
addnode=78.8.88.180:8133
addnode=77.35.255.255:8133
addnode=197.245.248.194:8133
addnode=195.91.186.23:8133
addnode=138.68.48.247:8133
addnode=2.139.88.157:8133
addnode=35.202.93.102:8133
addnode=76.90.44.140:8133
addnode=107.143.247.252:8133
addnode=189.202.72.85:8133
addnode=66.119.109.246:8133
rpcport=8232

Ok, thanks.

I have added those additional lines but nothing seems to change, I still see 0 connection. I have a zclassic.conf and a zcash.conf, should I also change the zcash.conf? I started the synchronization with zcashd

No, you have to change the zclassic.conf only. In my case it was working. But I didn’t install both on the same computer, because I was afraid that it will end up in chaos.

Here is the link:
https://github.com/z-classic/zclassic/issues/105

I am also confused by the P2P port now?

I am runing ubuntu 16.04.3, extract ZCL wallet from zclassic-1.0.10-1-f94256c-amd64.deb with dpkg -x, and copy the zcashd, zcash-cli to /opt/zclassic/bin/, then cat peer.txt to zclassic.conf.

But the zcashd will crash.

2018-01-01 03:35:29 Opened LevelDB successfully
2018-01-01 03:36:04 LoadBlockIndexDB: last block file = 6
2018-01-01 03:36:05 LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=9884, size=42040051, heights=199799…210614, time=2017-10-23…2017-11-11)
2018-01-01 03:36:05 Checking all blk files are present…
2018-01-01 03:36:05 LoadBlockIndexDB: transaction index disabled
2018-01-01 03:36:05 LoadBlockIndexDB: hashBestChain=0000000896ad3e9b22db491c8db0197bc128ae9a5b7ef732e58bb7ba530c49c2 height=209825 date=2017-11-10 05:00:10 progress=0.736302
2018-01-01 03:36:05 *** This version has been deprecated as of block height 209812. You should upgrade to the latest version of Zcash. To disable deprecation for this version, set -disabledeprecation=1.0.10-1.
2018-01-01 03:36:05 Error: This version has been deprecated as of block height 209812. You should upgrade to the latest version of Zcash. To disable deprecation for this version, set -disabledeprecation=1.0.10-1.
2018-01-01 03:36:05 init message: Verifying blocks…
2018-01-01 03:36:05 Verifying last 288 blocks at level 3
2018-01-01 03:36:05 Shutdown requested. Exiting.
2018-01-01 03:36:05 Shutdown: In progress…
2018-01-01 03:36:05 StopRPC: waiting for async rpc workers to stop
2018-01-01 03:36:05 scheduler thread interrupt

you got the wrong client version.

happy new year to all!

I have managed to start the sync on windows with the following config but now without changing anything the daemon crashes:

rpcuser=myUserName
rpcpassword=MyPassword
addnode=46.126.171.54
addnode=197.245.248.194
addnode=2a02:8388:8a01:1100:55e3:2656:54ff:fa6b
addnode=188.13.16.230
addnode=77.253.96.170
addnode=104.207.149.241
addnode=138.197.199.86
addnode=91.218.12.63
addnode=184.4.139.219
addnode=176.209.190.113
addnode=82.255.125.219
addnode=88.99.199.93
addnode=2a01:4f8:221:26dc::2
addnode=74.105.45.225
addnode=2a02:908:162:5efc:21f:bcff:fe09:5c62
addnode=87.103.195.162
addnode=68.234.31.67
addnode=78.94.32.196
addnode=158.69.183.22
addnode=120.27.230.83
addnode=138.68.48.247
addnode=2607:5300:60:ac0::1
addnode=89.142.65.151
addnode=198.100.147.192
addnode=60.170.218.192
addnode=79.98.144.29
addnode=2a01:4f8:212:1281::2
addnode=217.182.79.13
addnode=37.187.167.145
addnode=94.177.229.186
addnode=139.59.230.86
addnode=52.53.125.97
addnode=13.91.45.250
addnode=2400:6180:0:d0::17c6:e001
addnode=136.243.50.159
addnode=75.188.229.209
addnode=66.177.69.104
addnode=76.182.0.55
addnode=54.84.135.119
addnode=84.245.207.224
addnode=66.190.92.147
addnode=101.165.226.5
addnode=75.89.187.248
addnode=91.215.188.165
addnode=2001:0:9d38:953c:2c26:8d8:519b:e26f
addnode=217.166.97.38
addnode=76.24.40.93
addnode=68.60.109.183
addnode=172.249.44.225
addnode=73.65.184.66
addnode=187.181.14.1
addnode=151.202.33.171
addnode=64.39.73.2
addnode=96.29.230.162
addnode=135.0.251.101
addnode=109.15.167.1
addnode=2601:2c6:4a80:56a0:442e:aca6:1f4c:bb64
addnode=207.170.197.100
addnode=174.100.29.144
addnode=174.138.193.170
addnode=95.78.107.75
addnode=198.84.158.109
addnode=82.161.238.253
addnode=46.19.137.222
addnode=74.83.233.118
addnode=220.233.220.14
addnode=95.56.119.182
addnode=45.32.115.58
addnode=75.171.84.113
addnode=24.18.254.40
addnode=5.143.74.82
addnode=174.54.213.193
addnode=216.228.47.140
addnode=2a00:23c3:4aaa:b000:94af:ac88:35a2:542c
addnode=74.102.238.9
addnode=2a01:c50e:8824:d700:f05a:f723:fe3c:7923
addnode=68.104.58.47
addnode=98.230.121.23
addnode=88.24.78.71
addnode=82.24.216.124
addnode=98.168.137.138
addnode=47.62.219.193
addnode=24.228.56.53
addnode=209.181.61.219
addnode=50.82.45.123
addnode=209.194.2.18
addnode=71.231.198.79
addnode=208.107.54.154
addnode=162.197.26.236
addnode=184.54.109.70
addnode=188.167.68.208
addnode=196.52.2.32
addnode=118.92.193.153
addnode=87.123.236.140
addnode=64.223.106.104
addnode=94.78.207.1
addnode=82.17.137.87
addnode=142.129.74.38
addnode=73.42.176.102
addnode=67.183.29.123
addnode=70.162.238.217
addnode=217.75.222.33
addnode=24.17.178.164
addnode=2a02:a03f:4224:f300:81f6:f0fa:c30b:cb76
addnode=87.239.2.57
addnode=161.116.222.16
addnode=97.99.76.70
addnode=206.255.164.89
addnode=2001:0:9d38:90d7:24e7:2302:2314:5389
addnode=85.58.144.77
addnode=79.209.172.124
addnode=178.38.68.249
addnode=84.229.111.47
addnode=73.233.120.110
addnode=2001:8003:3898:8900:683a:32f4:3141:bb35
addnode=173.177.165.130
addnode=54.183.145.64
addnode=98.209.241.247
addnode=67.166.164.252
addnode=194.0.138.106
addnode=169.0.146.135
addnode=8.36.226.111
addnode=69.244.253.198
addnode=73.15.230.231
addnode=70.15.71.167
disabledeprecation=1.0.10-1
rpcport=8232

On linux, still no sync even with exactly the same configuration.

when I use: zcash-cli getinfo
I get:
{
“version”: 1001051,
“protocolversion”: 170002,
“walletversion”: 60000,
“balance”: 0.00000000,
“blocks”: 0,
“timeoffset”: 0,
“connections”: 0,
“proxy”: “”,
“difficulty”: 1,
“testnet”: false,
“keypoololdest”: 1514298407,
“keypoolsize”: 101,
“paytxfee”: 0.00000000,
“relayfee”: 0.00000100,
“errors”: “”
}

Am I missing something?

I tried this https://www.yougetsignal.com/tools/open-ports/ to see if port 8133 was open and it’s closed. I checked my routers to open this port but it doesn’t change anything. I directly connected to my modem (bypassing al routers) and port is still closed so there is nothing I can do to open it. I also tried my 4G connection with my smartphone and port is closed too.

Among the ones for who it’s working here, can you check if this port is open for you? If you get the sync to work with the port closed, it means that the port is not the issue .

Thanks

Yes, after compiling the latest code from github, finally the ZClassic node start normally.

Now my Thinkpad T440p with 1T hard disk, runing bitcoin node, zcash node, eth node, zclassic node, hush node, I will try to enable ZEN node. then try to mine 20 coins each of them:slight_smile:

Here 's the zclassic.conf that works for me:
addnode=dnsseed.zclassic.org
addnode=dnsseed.rotorproject.org
rpcuser=rpcusername
rpcpassword=yourrandompassword
addnode=70.15.71.167:8133
addnode=138.197.199.86:8133
addnode=91.218.12.63:8133
addnode=184.4.139.219:8133
addnode=176.209.190.113:8133
addnode=149.56.135.165:8133

I’m guessing what helped me is choosing nodes from here https://www.coinexchange.io/network/peers/ZCL
with the latest possible version.