ZecWallet Lite cannot restore on Ywallet

I have not pointed out previously that my wallet is on a virtual machine maybe that is of importance. I also am using Linux and I was told to try this method Import from ZecWallet Lite :: YWallet

I click properties and go to permissions and give it consent to run as a program/and without giving it this permission I get the same result
When I try running this through the terminal (even running terminal from the folder itself) it says

bash: zecwallet-cli: command not found
same result with zecwallet-cli.exe

double clicking does nothing

There isn’t instructions specific for linux I tried creating the wallet.zwl file with both zecwallet-cli.exe and sans .exe and it created the file but no wallet loads doing the “restore batch” step on Ywallet

I was suggested to try accessing the .config file and changing the settings.json file in the zecwallet lite folder but there is no such file in the zecwallet lite folder
there is however a zecwallet folder (not inside the zecwallet lite folder but in .config) and there’s a file called adddressbook.json
I tried creating such a folder and adding the server information and restarting the ZecWallet Lite but no luck, I even let it get to the point where I can enter the same custom server and no luck either.

What am I doing wrong? Any other solutions I could try?

Like I mentioned on the Discord, it sounds like you either have not built it right, you are not running it from the proper directory or the other flags like nosync are causing problems. If you copypasta the build instructions, it should work and start.

git clone https://github.com/adityapk00/zecwallet-light-cli.git

cd zecwallet-light-cli

cargo build --release

./target/release/zecwallet-cli --server https://lwd4.zcash-infra.com:9067

This will start the wallet and youll be able to export the seed and keys

Also on the Discord you saw the list of servers and their regions. You can find the one that’s closest to you and put it in place. The only difference will be the single number following ‘lwd’, actually. If you aren’t sure then you can use a ping tool and this will give you the latency in milliseconds.

1 Like

Thank you so much for your response. Edicksonjga seems to have helped me. I am waiting for it to sync now in ywallet. Easy fix I had the old version, needed to update.


It was a pleasure to help you! :+1::+1::+1: