Problems with old ZecWallet Lite wallet

Hey, been checking my ZEC wallet in ZECwallet Lite on Mac desktop app and can’t login anymore - I’m getting a not so helpful error message “Error: Couldn’t get network from server, connection refused. Is the server address correct?”. I can import the wallet elsewhere, but there balance will always show 0. Did I miss something (hadn’t checked for a long time, so maybe over the years things changed)

I tried everything to get my balance to show up in my ZEC wallet - nothing works.

Solutiondesk helpdesk kindly suggested to restore mainnet. Tried to do that through MetaMask, Guarda, Unstoppable. Didn’t work.
In Guarda, my ZEC wallet is consistenly returning “ZEC node maintenance. There may be temporary issues with ZEC operations and balance displays”
my ZEC lite on my desktop is returning “Error: Couldn’t get network from server, connection refused. Is the server address correct?”
I have no issues with any other coin.
Can someone please advise?

There are several posts here on the blog where the same problem has been addressed, search and perform what has been recommended.

ZecWallet Lite is no longer supported, the latest version is 1.8.8, I recommend upgrading to that version, wait to see if the wallet performs the automatic server change and if it doesn’t, try the solutions recommended in those other forum posts.

1 Like
1 Like

Hey @Edicksonjga saw your post on the other thread and followed your suggestion. Works like a breeze - wallet is now syncing - thank you so much :sunny:

1 Like


I suggest you don’t continue using ZecWallet because it is no longer supported, so when the sync is complete, migrate your funds to a new wallet that you can create in YWallet, Zingo Wallet, Nighthawk Wallet, etc.



Will do ; I had this balance sitting there, and hadn’t bothered for a few years - bad practice from my end - thank you for helping me out ; greatly appreciated! Can’t thank you enough…