1 out of 4 GTX 1070's consistently giving less sol/s in a new build

Hello,

I finished my first mining rig with 4x EVGA GTX 1070 SC Black Edition (6 when my extra cables arrive).
I use a MSI Z170A Pro Gaming Carbon with G4400 CPU and a Seasonic 1200w Platinum 80+ PSU.
I will connect 4-6 120mm fans when they arrive, to improve the airflow between the GPU’s.

Each GPU has it’s own PCI-Express cable connected to the PSU.
The powered USB risers are directly connected to the PSU with Molex with 2 risers per 6-pin peripheral to Molex cable.
I didn’t use the Molex to SATA connectors that came with the risers due to the reported fire hazard.

I’m new to this world and the world of overclocking (or undervolting) GPU’s, but I believe I do have some basic knowledge.
My current settings can be seen in the attached screenshot. I’m not sure if these are optimal, so tips are welcome and will be much appreciated.
I am currently averaging about 430 sol/s with EWBF miner.

The issue I’m having at the moment is that GPU0 (connected to the first PCI-Express slot) consistently brings 30-40 sol/s less than my other GPU’s.
I can’t seem to solve the issue by tuning my OC settings on EVGA PrecisionX OC.
Would the problem have anything to do with my current setup? GPU 0+1 are setup exactly the same as GPU 2+3 though.
Are there any other potential reasons why this could be happening?

Is GPU 0 the one your monitor is plugged into? If yes, then that is why.

That was my first thought, but no monitor is plugged into the rig.
I exclusively use Teamviewer.

so there is nothing plugged into GPO 0?

No, all ports are empty.
I'll make a photo when I get home.

Don't want to hack this thread but I am also facing same issue. If I disconnect the monitor, how will I use the computer?

Could this be solution to my problem? https://forum.zcashcommunity.com/t/poor-hashrate-after-adding-second-gpu-help/17275/1

If you have your monitor plugged into a GPU you are mining with, its going to take a slight performance hit because you are pulling resources away, best solution is to just turn it off if you aren't using it. If it isn't on, it is not pulling resources away from mining.

I'm sorry I forgot this thread. The issue resolved itself after a few restarts, I'm getting consistent sol/s for each GPU now.

hello, it happens when u are using TeamViewer, try not using it that often. TeamViewer makes GPU0 to give less hashrate.