ASROCK h110 BTC + 1080ti

What is the PSU u have or how are they powered

I have x2 evga supernova 1600 PSU connected with adapter

i hope not some sata/molex to 6pin or 8pin addapter

I meant the two PSU’s connect with adapater

1 Like

one question does it matter in which pcie are the gpus conected ? it is the same GPU faling each time or it is random

curious… didn’t you already post about this issue here?

you’ve been here long enough to know when you ask for help give us (details) information… you’re there we are not… if you are not detailed about your setup, we can’t help you.

Which details would you like to know ? I though I did

No, you shared a picture, what gpu it is and the MB type and your issue, thats it

why do I have to pull the information out of you?

It is your rig, DETAILS about your rig…, you built it… DETAILS

touch each piece and tell me everything about it

1 Like

riser version, USB cable thickens, or usb riser photo, Drivers version tried and if so how reinstalled
atc… atc … why SMOS btw

I wrote down that it is ASROCK h110 MB pro btc
GPU: Gigabyte 1080ti oc gaming 11g
Processor intel i3
Ram : Kingston 9gb fury hyperx
MB ver: 1.20
PSU: x2 1600 evga supernova
riser:007c

PSU #1: (Primary)
Connected to first 5 1080ti and to the MB
PSU #2: Connected with adapter to MB

how are the risers connected to psu how many are connected to one lead
BTW you should get better risers these are quete a crap the 007c get a "full board"risers search for verstion 009


connected with the SATA 15 Pin
First 4 card on the same lead
others 2-3

I know this isn’t helping you resolve your issue, but that connection setup is asking for a meltdown!

you should NEVER use an adapter from sata to anything.
and one sata connection (without the adapter) per riser

though power issues, that this can and will cause, could be part of the issue

1 Like

first problem sata rated for 4.5 A only u need to connect them on molex if possible that is rated for 11A
…even 2 on sata is quite a owerkill with 1080TI

CitricAcid imagine 3 x4.5Amps draving from one SATA power conector cable … the PSU have to be really good not to burn already


So I should use from each cable only one sata connector ? and connect to the riser right

well the 1080TI should drain about 4.5-4.6A per GPU from the PCIe but the questionable is the sata power connector rated only 1,5A there is a possible meltdown of the connector anytime + a shortcut that would minimal kill the riser as per the photo it is a full board version with at least a basic protection circuit so your gpus should survive in such case
but i would not test it if i would you still it is china :smiley:

BTW what other spare connectors do you have on the PSU

With the PCI-E slots so close together on this mobo, have you considered (like others) putting some electrical tape on the risers to prevent them sorting? (should they touch for one reason or another)

I got electrica ltape on the risers

1 Like

My understanding is that this cannot be done with more than 8 Nvidia GPU in Windows. You need Linux. once suggestion is to try SimpleMining OS supposedly they can support up to 13GPU but I have not tried it personally.

1 Like