Asrock h97 issues

So of course only rig that was on power without surge protector shit the bed.. So RMA'n it and bought z97 cause it would get here the soonest and relatively cheap.. So plugged it in with one card just to make sure everything was good. No worries there, then the rest and BAM**** like a kick in the nards nothing. It would at first boot into windows but wouldnt detect the other cards.. SO I started to play detective with the good ol trusty screw driver and did one card at a time ( adding them ) but wouldnt work.. NOW it wont even boot into windows at all, just past POST screen then black,.. Tested cards on same rig in PCIE x16 slot they all worked. Tried ribbon cables and work. Updated bios from 1.90 to 2.0 and still nothing... IDEAS?!?!?!?! would be much appreciated

Any thoughts??? Tried new PSU and swapping ribbon cables with ANOTHER Win10 install and nothing.,,,

What cards are you using?
Do you have powered PCI risers for other GPUs?

PCI-e lanes can only power up to 75W ... combined! All of them 75W only.
That's why powered PCIe risers are good idea.

Does your system boot with only 1 card?

Im using Gigabyte R9380 4gb with ribbon cables ( my other 8 rigs which have h81 pro btc use same ones )
The computer boots with all cards plugged in but like I said nothing else... Nothing hidden in device manager or anything

Did you check in BIOS for settings that would allow you to use multiplie GPUs?
Usually motherboard will only allow 1 GPU to work, so you need to find that option in BIOS and turn it on.
What CPU are you using?
Are you sure there are even enough lanes that CPU supports?

Same CPU on all other rigs lol... I'm not sure what option that would be in BIOS

I can't say for sure, I just know that some people had those problems on other forums and they found some settings in BIOS about GPUs.
Not 100% sure if that would help you.

Why didn't you just order that BTC motherboard that you are using in other rigs?

Sold out everywhere in Canada I would have to order off ebay ( which I've gotten melons before ) and drive to boarder to get it... I went with ( what I thought ) was a safer bet lol

I'm looking for those topics now lol

Were you able to find anything? I have have been pulling my hair out for last 3 days to run 6 GPUs (RX480) on Asrock h97. Its on Ubuntu 16.04. I'm able to see 4 GPUs only.

Nothing,, It's super annoying!!!!!! If you're not opposed to Window's 10 try that! it worked great for 6 GPU for me ! I think it's the board with no molex connector!!! even though it show's on the box it should have one LOL stupid computer store!!!!!

Are you running powered risers

Yes I'm running powered risers. Looks like I was able to get 5 GPUs to work so far with Asrock 97, by changing PCIE1 Link Speed to "Gen2" in UEFI(BIOS) settings:
Imgur
Imgur

I could be wrong though, but I think this issue has nothing to do with type of OS. Its just some setting in BIOS that we are missing.

Not on that motherboard. It has a MOLEX power connector for the PCI-e buss:

If you use it AND powered risers you’re asking for something to be burnt out with too much power on the PCI-e buss.

Mine didnt have the molex connector!!! Bought powered USB risers and WORKING!!!! fucking finally

2 Likes

Good to hear! How many GPUs do you have it running on?

4… Thats only the number I could get, it isn’t the one pictured above, it only has 4 pcie and 2 pci :frowning:

@theneogeo82 @neoMiner Check and double-check your risers. I have a couple of 6 GPU rigs with the H97 anniversary and they run fine, but sometimes the riser cables lose contact. Set the PCIE Link Speed to AUTO. If your rigs don't recognize 6 cards with that setting, then it's likely a hardware problem. Check that all of your risers are good, I have one from Amazon that was visibly defective on delivery.

@cascadiacrypto The H97 anniversary needs the PCIe molex plugged in just to boot with more than 4 GPUs, so there's not much of an option if your using this motherboard. I'm using it with powered risers using molex cables (no cheap SATA to molex cable that it came with) and it's fine. If you guys need extra molex cables, just put in a support ticket with the manufacturer and ask for them, you can plug in as many molex cables as you have SATA ports. EVGA was kind enough to send me 4 extra molex cables.

I got it working with powered USB risers.. The board I got did NOT have molex on it

Thanks @vgm You could be right about the risers, when I twist/turn/move the mobo to riser connector, so GPUs randomly show or vanish :frowning:
New risers cables are on it way, hopefully that fixes it. I got this one: https://www.amazon.com/gp/product/B01GU94QSQ do you know of any better quality sources?

Yea, those pcie x1 lanes don't have enough power.... it was my last suspicion.. Glad we got it all figured out