MSI Z170 7 GPU BIOS Setting step by step

MSI Z170A GAMING PRO CARBON have 7 PCIE-E slots,it’s a good motherboard to build mining rig.

Old BIOS is hard to MOD and only can run 6 GPU at same time.
How to use old BIOS MOD to success 6 GPU see my blog old past (link)

2016-12-26 MSI release new BIOS version 1.7 for Z170 and Z170A motherboard
It’s easy to setting and successful mining 7 GPU at same time.

My mining rig:
(1)CPU : Intel® Celeron® Processor G3900
(2)Motherboard : MSI Z170A GAMING PRO CARBON
(3)GPU : MSI GAMING X RX 470 4GB * 6 and MSI GAMING X RX 470 8GB * 1
(4)Memory : Kingston 8GB DDR4 2400
(5)SSD: 120GB
(6)PSU : CORSAIR RM1000X
(7)Other : USB 3.0 PCI-E Express 1x To 16x Extender Riser Card Adapter X6
(8)System : Windows 10

Step 1. Download BIOS Version 1.7

Step 2. Unzip and put BIOS file E7A12IMS.170 to USB flash disk root directory.

​Step 3.
Shutdown computer and don’t plug in anything on PCI-E slots.
Only plug in HDMI cable and BIOS USB flash disk.

Step 4. Boot up and into BIOS and press F7 to Advanced.

Step 5. SELECT M-FLASH

Step 6. Press Yes to Auto reboot enter flash mode.

Step 7. M-Flash mode

Step 8. Select BIOS file E7A12IMS.170 and press YES to flash BIOS.

Step 9. Waitting BIOS Updating

Step 10. Into BIOS
Settings>Advanced>PCI subsystem Setting
PEG 0 and PEG 1 set to Gen1
Above 4G Decoding set to Enabled

Step 11.
Settings>Advanced>Integrated Peripherals
Unchanged

Step 12.
Settings>Advanced>Integrated Graphics Configuration
Unchanged

Step 13.
Save change BIOS and shutdown computer.
Plug In all USB extender riser and HDMI cable plug In Graphics card.

Step 14. Boot up into Win 10 the 7 GPU is get.

Step 15. ETH mining Claymore can detect 7 GPU.

Step 16.
MSI GAMING X RX 470 4GB *6 +
​MSI GAMING X RX 470 4GB *1 = 195 Mh/s ETH

Step 17. This is my 7 GPU mining rig

Step 18. This is easy to build 7 GPU mining rig.

Tuning GPU see my blog: How to distinguish GPU quality to tuning your GPU

RX 470 4GB BIOS MOD see my blog:MSI GAMING X RX 470 4GB BIOS MOD Hynix chip ​28 Mh/s

RX 470 8GB BIOS MOD see my blog:MSI GAMING X RX 470 8GB BIOS MOD Micron chip ​28 Mh/s

​Hope it helps you.

10 Likes

Thanks for this. I have a few MSI Z170A Gaming M5 boards that I'd lost all hope for!

1 Like

good work!
thank you

This helped me out a lot. I was able to get from only mining 4 RX480s (crashing on boot with more than 5) to mining with 5 GPUs. And I can get a 6th GPU detected. However, I am having problems with 6 GPU. I am using risers 1x to 16x from mobo. I have them all plugged into the 1x slots on mobo, and 1 in the 16x PCI slot. There are two more 16x slots on the board that are silver, when I don't have any GPUs plugged into those silver 16x, everything works fine - but I can only run 5 cards.

If i put a GPU in the silver 16x slot closest to the 1x HDMI PCI slot, then that GPU runs at 100% fan and mines very low hashrate. If i put it into the other 16x slot that is silver, the card is not detected. have confirmed this with two different cards.

Anyone have any ideas?

1 Like

我會試試這板子

但是7張RX470用1000W power應該不夠用吧

Cool hah.

But link to moded BIOS dont't work.
Can you give correct link to Micron memory BIOS?

Thanks

Hi Did you make all 6 or 7 gpu works on MSI Z170A Gaming 5?

Im having trouble making all the GPU work on this board. Hope you can help me.

I did the same, installed 7 rx480 8GB cards. Flash using msi bios update. And here is where it went nuts. I updated the drivers to the latest one and the motherboard only saw 4 cards. After that I did a clean uninstall of the gpu drivers with ddu and installed the driver version 16.9.2 and after that all the GPUs came out on the device manager. After that it was all smooth sailing. =D

I ordered a MSI z270-A PRO 1151 board and a asus prime z270a boards. I plan to go 7 card rigs once I get my first 3 rigs back up and running, I have 2 pro btc boards and a fresh anniversary board as well - Those will be the first 3 boards I use. . I'm gonna throw up 3 quick 6 card rigs first, I'll try to put a 7th on there when my splitters come in. I ordered some 1 to 3x splits, and a ton of other adapters. I got about 10 of everything concerning pcie to x adapters, I like having extra routes when troubleshooting

Anyone ever tried one of those PCI to PCI-E 16x to 16x adapters? The non powered ones. seems like the ones that are 32 bit converter adapters , you know, would solve this problem we're having.

If you take a look at the motherboard spec sheets, it's surprising how many of them have PCI slots are the very ones people are complaining their PCI-E riser 1x chips don't work in. I guarantee if those slots were PCI-E 16x, that PCI-E 1x chip would work.

I think thats why the goddamn adapters are 40 on ebay and amazon, I'm trying to snag a test order from a bulk guy in china....gonna be a few days im sure

Thanks for tutorial, mobo bios update work properly.
Now I added 2 MSI GAMING X RX 470 4GB BIOS and try to modify timings as you written on blog.
On both same problem... I modified bios, flash it though windows 10 and after reboot modified card fans working, and there is error in device manager.

I am using Crimson 16.12.2 driver, try to reinstall it, move between slots, same thing.
Sometimes I couldn't even boot to windows after flasing, until changed Gen1 to auto for 1st boot.

Possible problems I am thinking of:
- should I use older mobo BIOS for flash GPUs, or do it on another mobo?
- should I try to change the drivers
- should i try to run atiflash though usb in DOS and repeat?
- should i try -unlockrom ?

Thanks.

I successfully boot with into win with flashed bios using 16.3.2 crimson up ti 4 gpu.

I cannot boot into with 5 and more.

Any suggestions what to do :/?

hello a
does anyone know which is the best Bios for
Asus prime Z270-p
motherborard to run 4/5 +Gpu ?
thanks in advance

You have to wait for the drivers to be installed for all the cards after you add new cards.

I added one by one and waited for 3 minutes on black screen at last one and rebooted few times and same. :S

Apart from updating BIOS to the latest one, you have to make sure risers are tight enough connecting PCIE slots. MSI Z170 PCIE slots are not so good as MSI Z270 Krait Gaming. I have tested both MBs and it works properly without any errors.

Looks good @mining-hardware. How did you get 7x RX470 on a 1000W PSU? Did you have to install a second PSU?

1 Like

Hello, I'm new to the forum,
my configuration:
Intel Celeron G3930 7th gen(Kaby Lake)
MSI GAMING Z170A PRO CARBON
Kingston 8 GB DDR4
Intel 120GB SSD
7x Sapphire Rx 480 8GB OC (with modded bios)
EVGA Supernova 1200w

I installed the new BIOS and then installed the modded one, but every time I try to boot into windows it shows a backlit black screen and whenever I try booting a UEFI install usb it shows the windows loading circles and then backlit black screen. I've left it on for 24 hours with the same result.

Without the 4G decoding the system is fine, but whenever I try turning it on the system just does a backlit blackscreen, also I have PEG0 and PEG1 set to Gen1

What should I do? I'm really desperate right now, any help is appreciated.

Hello;

Did you find any solution for this problem also i had face many times as same as your problem. when i enable 4g decoding windows can not open and reboot constantly.

I'm using Rufus since you can't only install UEFI windows 10 using Media creation tool. (whole album http://imgur.com/a/wWItY)
So these are the bios settings currently: (All images are from Imgur. Also since I can't post more than 1 link and 1 picture since im a new member I will only post the last part of the URL. Use the 1st image as a reference.)

/sQpGInR.jpg
/yugLee4.jpg
/7pZEppT.jpg
So it boots with the bios logo.
/kJDiTKA.jpg
Then it shows a loading screen without the windows logo.
/wMmyCuw.jpg
After that it shows the loading circles with the msi bios for a split second. (literally for 1 second, but somehow I managed to get a picture of it)
/gyyJF7g.jpg
Right after it shows the backlit blackscreen.
/JY4UPfj.jpg
I have been using the modded version of the bios already. I have also tried the 1.7 Official version. Both do not work.
I also have tried using only 1 GPU(not on riser), no cards(using on board Graphics), 1 GPU(on riser) and all GPU(on risers).

I read elsewhere the Kaby Lake processors are having a hard time running anymore than 4 GPU's on certain motherboards. I have the little brother version of the OP (MSI Z170A SLI with only 6 PCIe slots) and can confirm using a Skylake processor that I can successfully run 6 GPUs on the board after the latest BIOS updates.

If you have a spare 1151 Skylake processor laying around (or if you want to order one), you might try this route before ruling out the board completely.

An interesting aside, the latest BIOS is a version or two ahead of the one the OP posted, and the "Above 4G Decoding" setting is now renamed to: "Above 4G Decoding/Cryptocurrency Mining" so indeed MSI is now fully aware of the end use of these boards.

1 Like