Balance issues

Hello, I am a new user and I’m experiencing problems restoring my YWallet account. I had not accessed the account in many months due to various issues and when I tried recently my ZEC was missing. I updated the app, but it was still missing, so I tried a rewind and rescan without any luck. I also tried restoring my account with my 24-word Backup Key and my Secret Key but no luck. I tried searching topics but have not found anything to help. Any help would be appreciated. Thank you.

1 Like

There could be a number of reasons for this but if you did not rescan far enough back then the funds would not be found. After a full rescan, there should be a complete tx history to correlate fund movements.

1 Like

Thank you. I did a full rescan and still do not see any ZEC balance. I have the transaction hash and can see that it was confirmed on the ZCash explorer but can’t seem to get it to show up in my wallet.

1 Like

Is this a transparent balance?
Any transparent funds won’t be immediately visible on the Home Screen, it only shows shielded funds by default, but you can swipe the QR code to left to cycle through your addresses to the transparent at the very far right. Prior to 1.5.3 (4, now) you would tap the QR Code to cycle through the addresses. Also, if they are transparent funds, they may not be immediately spendable if A. you also have shielded notes (shielded notes are automatically selected over transparent, you would potentially need to exclude them in the ‘notes’ tab) and B. have your min privacy level set too high.

Thank you for your help. I believe it is as the address starts with a t. I have cycled through all addresses and still have a zero balance. This is very frustrating as I see the confirmed transaction and I’ve restored my account and did a full rescan.

1 Like

A ‘t’ would indicate transparent, yes. Do you have the txid assiciated with the transaction?

Yes. 7257258178a5bbf8d122a55575d1f3a518fae2724f24cbe8a1ad281639d0efbe

And its the address ending in s7qphu, I assume? Or does your wallet show a different t-address?

What wallet did you use to make this transaction? It is not from ywallet …

I infer that they are on the receiving end of the transaction. If they had sent those funds from ‘NiQ68n’, the balance showing 0 for it would be correct.

It was from Binance to YWallet

My wallet shows a different t-address but I only had one wallet and I restored with my seed so I’m not sure why it is different.

And I verified the ZEC was in my Ywallet after the transaction. It was in there for several months and then I stopped checking it due to life situations and when I recently went back in it showed 0 after the app updated

One thing to try is the key tool in the settings. It (the little refresh button) will generate a batch of addresses under your seed and your taddy might be listed there. There is an ‘external’ option you might uncheck if you cant find it. If you do, then you can select it and import it into your wallet.

It is curious though. If the balance was correct previously (few months back), then that means that the address changed because otherwise you would not be thinking it was a different address than the one you have and would likely mean that the wallet seed changed.

The funds are still at t1dpKb692qNYnqp6nKyezZg4veaJPs7qphu. If that’s supposed to be your wallet address then check that ywallet shows it. The app update doesn’t change the account data.

1 Like

Trying the key tool but when I select it the screen goes blank. I’ll reboot and try again in the morning.

1 Like

I should have asked sooner, but what kind of a device/OS is this running on?

I always used my iPhone but also installed the windows desktop version when trying to figure this out.

How did you back up the seed that you are trying to restore? Did you write it down when your wallet was working?
The reason I ask is because if the wallet cache became corrupted for whatever reason, then the wallet’s normal functionality would be to generate a brand new wallet and new seed. This might explain why your address anf balance changed; because perhaps the seed changed as well. And if you are attempting to restore this potentially new seed because you think its original, then it would only ever give you these new addresses and 0 balance.
Be sure to verify that the seed you are attempting to restore is the same as your backed up seed from the working wallet.

I wrote it down and took a screen print.