Behind the NAT there is only 1 connection


#1

I have only 1 connection behind the NAT which is very confusing. Yes, i know i should forward the port but what if i have several machines in my appartment? They will find each other in the lan and mine for themselfs if i run them instantly on the day one. Their blockchain will differs from the official blockchain.
I mean when i use bitcoin or bittorrent it always connecting to many peers behind the nat but zcash doesn't . What is the problem?


#3

See https://github.com/zcash/zcash/issues/1416 .


#4

@Geomancer @daira which port do I need to forward? Thanks


#5

That could be HUGE problem after release, because all users under the NAT will connect directly to main zcash server. And they will act only with that server. That doesn't sound like p2p currency :joy:


#6

I had same issue, forwarding port 18233 (for testnet) seems to have solved


#7

That's not correct. Each server outside the NAT will only be able to connect to one of the servers inside the NAT, but each server inside the NAT will still be able to connect to many servers outside. This is identical to Bitcoin, so if you consider Bitcoin to be a P2P currency despite this behaviour, then so is Zcash. (Note that in previous testnet releases, DNS seeding was not set up. Now it is.)