Can only get 1 GPU Working Windows 10 Code 12 error Nvidia Cards Mining Rig Setup

This is my first PC build everything was straight forward and working using EWBF nicehash pool until I tried using 2 GPUs. Using 1 works just fine hashing zCash at 283 Sol/s with Nvidia card I want to get it up to a 6 GPU mining rig but knew I would encounter issues so i’m just starting off with 2 cards.

The second GPU in the device manager settings I get a code 12 Not enough resources

Specs for the build are…

Motherboard: ASRock H81 Pro BTC ATX Motherboard ‑ LGA1150 Socket
Processor: Intel Celeron G1840 Processor - BX80646G1840
GPU: 2 x MSI GTX 1060 AERO ITX 3G OC Graphic Cards GTX 1060 AERO ITX 3G OC
PSU: EVGA SuperNOVA 1000 G3, 80 Plus Gold 1000W, Fully Modular
RAM: PNY - 8GB PC3-12800 DDR3 DIMM Desktop Memory - Green
OS: Windows 10 64 bit (un-activated)

I have tried many things including re installing gpu drivers, adding gpus one by one, you name it but still getting code 12 when both are plugged in (for one GPU in pcie slot 2). It’s work mentioning I am using PCIe riser cables ver 007. Also, both GPUs are fully functional as i’ve tested them both out and at one point they were both running but ended up getting a code 12 after about an hour or so after mining.

Any thoughts or advice would be appreciated


Just to ask… have you updated the bio’s?
Are there two PCEI slots on the mobo? If yes have you tried running the GPU’s directly and not with the risers?
Does a solo card work in pcie2?

If you are still having the issues and your bio’s is current, go in turn off the I/o port, sound, and usb ports you’re not going to use. That will free up resouces

ok so error code 12 in dev manger is that device cant find enough resources to run that means GPUs are working is just the stupid windows blocking it for some reason .
first of all i would try to switch to test mode . open CMD as admin ant type bcdedit /set testsigning on turn of the system then start it go to bios set the PCIe to gen 1 or gen 2 then let it boot to windov you should see a watermark in the edge informing you that testing mode is on now in the testing mode use DDU uninstall the driver and try to instal the drive directly downloaded from MSI and dont forget to setup the virtual memory … let us know the result …

or switch to linux right away

1 Like

Bios is at most recent version from 2014. there are 6 PCEI slots if i’m not mistaken (i’m very new to this so bare with me) and if just one card is in pcie2 (16 x slot) which I believe you are referring too, it’ll just be a blank screen at least with the riser cable. My specific GPU won’t exactly work without a riser cable on this mother board since metal piece is too long.

I have also turned off all unnecessary peripherals that you suggested in bios (sound, i/o, etc.) to no avail. My next step is installing linux do you think that might help?

Yes I believe you’re right do you think linux mint is alright? I’m seeing some good youtube tutorials so thinking of trying it out. Also, will give that test mode a try I turned off the system for today since it has been a real frustration just trying to get multiple GPUs to run, will get back tomorrow on an update to see if either the test mode or linux comes up with a solution.

1 Like

based on the prev replay (blank screen with riser) are you shore you setup the the PCIe on gen1 or gen2 risers have problems with the setting on default (it will set it automatically on gen3 since the gpu supports it) or gen3…with linux you should not have any problems it isnt so messy and picky as windows 10 (especially the 10) … the testing mode will turn off some “security”(crappy worthless stuff like blocking unsigned drivers for example ) features that prevent sometimes the drivers from installation and correct work so it is worth a try at least

I’m deciding to just go with linux since it’s seeing both drivers as working but my problem now is with Linux and installing the nvidia drivers (what a process this is). When I get into the grub menu root and install the drivers once I reboot i’m faced with a black screen showing about 10 lines of random numbers and after each one is the statement “No discrete VGA device found”… and no keys will allow me to get out of the menu so i’m having to take the power out to get back into the grub menu. Any thoughts on why this is happening?

ok so the only thing that comes on my mind is to setup in bios/advance manu/chipset config and sett primary graphics to PCIe(also called dedicated GPU ) and plug the monitor to the GPU or set it to onboard (also called discrete gpu ,the intell one in the CPU but you will need to install drivers for this as well ) and connect the monitor to the motherboards connector
edit : here i found a video may be useful for you

1 Like

Thanks for your help!

Both GPUs are running nice… Nvidia drivers were already plug and play with linux I was making it complicated and getting into computer science territory.

Moral of story for other newbies starting out with mining… pick Linux as your operating system.

1 Like

happy you get it sorted out and you are now up and mining :smiley: like win isnt bad it is easy to setup until everything works but when dosent it can get much more complicated to find and sort the issues out that with linux which is pretty strait forward :smiley:

1 Like

My guess for your Windows problem is you didn’t increase the size of your swap file. I had to increase mine to 20 MB when mining in Windows with an 8 card rig.