Zcash4win updated to 1.0.8

The beta of zcash4win has been updated to incorporate zcash v1.0.8 and the latest release of the Swing Wallet by @vaklinov

The address book is now back in the main tabbed interface screen, and zcash 1.0.8 has quite a few improvements under the hood.

As always, latest release is linked at https://zcash4win.com

If you're upgrading, you need to go into "Add/Remove Programs" and uninstall the previous version before installing the new msi file.

Our donation page again is at zcash.mercerweiss.com/index.html#Donations and has addresses for BTC, ZEC and other cryptocurrencies and paypal. I still need to raise enough to get a code signing certificate to banish the warnings when you download/install, and am also short for rent a few days, so please donate if you can, every bit helps!

Thanks again for the communities support, and comment here or via email (radix42@gmail.com or david@mercerweiss.com) with any issues you run into.

Cheers,

David Mercer
Tucson, AZ

4 Likes

Hi, I uninstalled previous version and installed 1.0.8 and am now getting this error message:

A general unexpected critical error has occurred: com.eclipsesource.json.ParseException: Expected value at 1:1 See console output for more detailed error information!

What shall I do next.

Also....When I use powershell with 'C:\Program Files\zcash4win\app\zcashd.exe' does nothing and still wont start.

Thanks,
Jeff

Thanks for your work on the wallet. It works really well. Jaxx wallet failed to make any zcash transactions the other day so I imported the private key into Zcash4win.

I sent a small tip to you as thanks. It's only small but I hope others leave you a tip too.

1 Like

Try launching it in powershell as:

C:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

and also look at the end of %AppData%\Zcash\debug.log to see what's going on

Thanks, every little bit helps!

Any chance we could get an email notification option for wallet deposits in the next version? Love the app!

oh that's a great idea! but it has some privacy and security issues that are....challenging! and I say that as someone who has wanted that feature badly myself.

i am using the 1.0.8 … SHA255 is totally different from the original post

Hash for the current release of zcash4win-1.0.8.msi is indeed
e3a8f5179e5a1ce1bddfa6145a9be0c4827d08cba852edf04d127ecc1c49dd31

Hi will you be updating to the new version?

yes, but the 1.0.9 release doesn't contain new features or critical security updates, so it may be a bit...its mostly internal stuff so they can measure code the effect of internal code changes on performance

Great product -- hope to see this get more mainstream adoption in the near future. Only recently heard about it a few days ago myself. Much better than Jaxx IMO for Windows users.

I was playing around with sending and found that if I tried to send the "full balance" of an address to another, I had to grind out some math to get it to accept it without errors.

Any plans for a future build that will auto subtract necessary fees when you try to send an entire balance of an address to another?

Thanks.

We might add that and the ability to send from more than one taddr at once, which you have to use the command line to do right now

Thanks for your work on this.

Interesting that you mention that -- Something I observed when I was sending a small amount, specifically .002 to an external wallet not managed by zcash4win; I observed that it actually sent a larger amount and created a new address for me. I briefly ended up with an additional address showing up in zcash4win that contained .01683514 while the .002 went to my external wallet.. It was afterwards when I noticed it and then tried to send the .01683514 back to my primary zcash4win wallet and had to some math as referenced above. I'm not sure if this is by design for zcash or not as I'm new to the coin.

After I sent the entire balance from the address it created back to my address, the other address in my wallet disappeared. It was very odd. I can direct message you in some way the blockchain transaction if you want to see it but the above is the specifics to what occurred and how it occurred.

At the time this was done, the wallet had more than .10 zcash within it.

by default when dealing with taddress funds it does what bitcoin does (as of 0.11.2 when zcash forked from it), which is by default send change to a randomly created new address: the GUI isn't doing that, its the underlying zcashd. That can be over-ridden if you cook up your own transaction by hand, and we're gonna look at the various other things that are possible with change, etc.

Ahh, I thought this might be by design -- thanks for the confirmation. Pretty cool feature and would definitely be nice if it would go as far as to put the change back into the primary wallet since I don't think you can send from multiple wallets at the same time a "combined" amount.

The bitcoin command "sendmany" (NOT z_sendmany) works for taddr funds in zcash on the command line...if you don't give it a "from" address it pulls from as many taddrs in your wallet are needed to send the amount you specify. Its useful for sweeping up a bunch of little amounts scattered between different adresses from change, etc

Hello there,

I get this error unfortunately

I tried your solution from 16 april but it didn't work

vifzor

which fix was that? was it to let the node sync by starting it up in command line mode? if not that's what I would suggest