[EBWF] With time the number of Sols/s decreases


  • Windows 10
  • 1 x MSI 1080 TI Gaming X
  • 4 x MSI 1080 TI Armor OC
  • Core clock is 100
  • Memory is 260

When start avg sols/s is 745-750, but with time we can see GPU4 have 590 sol/s

Temp: GPU0: 53C GPU1: 63C GPU2: 70C GPU3: 67C GPU4: 58C
GPU0: 767 Sol/s GPU1: 751 Sol/s GPU2: 761 Sol/s GPU3: 739 Sol/s GPU4: 590 Sol/s

I have something similar, but from the start

i have 6 x 1080 TI, and i get ~740 Sol/s from 4 cards, but two others i get only ~670

anyone has any idea why ?

i think its windows problem. because i turn off gpu from device manager and turn on back, but it doesn’t help.
So i want make some test on ubuntu(linux)… because havent any idea.

its a EWBF thing, but also windows related.

problem is dat the devfee starts a new session and leaves it open. But when the next devfee point starts it opens a new session. Over time you get loads of sessions and if you want long enough you might loose connectivity(max sessions)

Just restart it once a week! Or, like me, patch EWBF not to mine for dev anymore.

u say need to patch, u are close connection to host when devfee try mining? or what?

and u say about socket connection, right?

removed the dev mining code entirely

and yes its the socket connections that fill up. You can see it with netstat, looking at max connections and the eventlog showing max connections was reached.

hm, where i can find the source code of this project?

In Linux and EWBF you will see GPU0 (the one with the GUI running) will have a slightly lower hasrate than rest of cards. Also need to be more gentle on the OC on GPU0 or it with restart the miner more often. I did see once that a card was running with low hash rate but the miner watchdog saw it and restarted (I don’t let GPU hash fall below 650 on any card).

I see two additional items that it could be:

  1. when you start a new session, your cards are cooler. As they come up on temp, they lose some Sols/sec because of this. This is especially true if the computer doesn’t get good airflow.
  2. You mention a drop to 590. That might be a component in the riser not working correctly. I have had to replace some part of the riser before due to dropping in Sols/sec. When I did, the issue resolved itself.
  1. I set manual fan speed to 100% when start, also air flow is also goos( air conditioner on gpu )
    2 Ok, i will test to change positions of cards

I have normal speed 740+, but after 1-2h one or two cards go decrease speed

its not open source, i decompiled/patched it

Can u suggest good decompiled soft? I try do that

What are the temps on you cards after 1 or 2 hours vs when you just start? You will have head soak that in my experience will reduce your sols/sec by just a bit. Ususally about 2-5% of your cold start number.

As an aside, do others find this to be true as well or is it just me? Ha ha it does get up to just south of about 100 degrees in my office with all of these computers at about 5PM…

I really don’t like this. If you don’t want to pay the devfee, don’t use the miner. If you want to take advantage of EWBF’s optimizations, pay the dev. What you’re doing is stealing.

1 Like

Well all good and fine, but enabling it crashes/creates problems every 5 to 6 days to bugs which are reported but never resolved.

Instead of going to all that trouble can’t you just use --fee 0 ?


anyway, setting fee to 0 removed the counter interval for mining dev … but still seems to open connections, etc :frowning:

Interesting to note. Thank you for mentioning this.