Running miner kills network connectivety


I have a usb wi-fi dongle plugged into my asus prime A with 5 x MSI Gaming X running.

The issue I’m having is that as soon as I run the EWBF or any other miner the dongle drops out, I am unable to ping ( it drops out the exact second the miner tries to connect to a pool)

Strange thing it was working fine an hour or so ago but my GPU was causing issues and kept stopping or losing connection to the pool

I also have another miner running using a wifi usb dongle and have no problems with this so don’t think it’s an internet issue

Any ideas?

Switch dongles and see what happens.
Do you have a firewall on the failing machine?
Do you have a firewall on your network that could isolate that computer once EWBF becomes active?
Can you assign a static IP address to the dongle and see if it continues to act the same?
If a Windows computer, run “route print” from a command prompt and see if there is an errant route to your pool.

Hope that gives you some guidance.

You may install wireshark and look in to the traffic too… what is going wrong.

I’ve switches dongles and it happens with both, weirdly my other mining rig is doing the same thing now so guess it is a network issue .

I have turned off windows firewall but it was working all day with it on, only in the past few hours has this problem happened.

I will try wireshark but always struggle to tell what is what amongst all the traffic

running print route i see this:

IPv4 Route Table

Active Routes:
Network Destination Netmask Gateway Interface Metric 55 On-link 311 On-link 311 On-link 311 On-link 331 On-link 331 On-link 331 On-link 331 On-link 311 On-link 331 On-link 311

Persistent Routes:

So i’ve also tried it on my laptop and this doesn’t kill the network on it so the only thing in common is that I did a fresh windows install yesterday on both mining rigs, to me it doesn’t look like a network issue

Can you connect a cable to one of those computers and see what it does? What if you change pools?

unfortunately I don’t have an ethernet to test with, It does the same thing for the lbry and zec pools on suprnova and running the default start script on ewbf to nanopool also drops the network

Do you have a smart phone? If so, can you connect your dongle to it and try?

Have you fully updated Windows?

I have a smart phone but not sure how I would connect the dongle…

WIndows is fully upto date, tcp/ip settings looks fine, hosts file is normal,

It is because Graphics Cards interferes your WiFi dongle with radio frequencies. Either use cable connection, or USB cable between port and dongle. Also, as a temporarily solution, try to use foil, just wrap it around dongle and look at ping utility at the time.

@Replacer I’ll give this ago as a long shot, but I have had the mining rigs running for weeks with the same USB dongles , I’m going to try ethernet tonight so guess I should be able to determine if this is the issue

I’m just curious. WiFi adds to latency which can affect the number of solutions or shares you provide. Is WiFi an absolute must in your situation? My line of thinking is there’s no benefit to WiFi when mining unless it’s literally impossible to get a wire to your miner.

Just some food for thought.

My rigs are about 15 meters away and the cable would need to go under a door also so wifi is the easiest option and when the rigs are running I seem to earn around what it says on so not sure wifi is to bad.

I will try ethernet tonight to see if this works , if so I’ve just seen you can get a flat ethernet cable which would probably solve going under the door so could definitely be a possible option

It could also be my router - Comtrend VR-3031eu - which is awful. I ran a constant ping to it and the rig dropped offline so will need to wait until I finish work to check if it’s because of this.

You create a hot spot on your phone. Most smart phones have the option where you share your internet connection through the phone just like any other wifi device, though there may be an extra charge for it - depending upon your carrier. Once you configure your phone as a hot spot you then configure your dongle to connect to the hot spot on your phone. If this works then there is something wrong with your wifi.

1 Like

@Replacer you sir are a legend! as soon as I wrapped a piece of foil around the wifi antenna it started working

Thanks for everyone’s help finally have this working after a few days!!

1 Like

I WAS using cable to connect my main computer as its wifi antenna the mobo came with never worked, also I don’t like wasting speed and that would happen unless I buy something like a TP link Archer pcie receiver with 1gps + speed…but won’t work on linux because of drivers issues so I discarded that option…

Before setting up the rig I took a tp link router and made it work as a bridge for the root modem which also broadcasts wifi…but my isp has configured their modem like s*** and won’t allow me to enter to do it myself so all of the ‘‘receivers’’ are working at one third of capacity, say my tp link bridge has a speed of 300 mbps but works at 100, the dongle connected to the rig has 150 and works at 64…a total joke

So now, I am really considering going back to cable, I have a promedy of 300 ms which is not good as I’ve read
the only problem is that the cable has to go through the living room and looks pretty awful lol, but I think I will get some tools and those cable hiders for walls and go back to enjoying 1gbps

WiFi is bad for mining. if you can’t connect it directly with network cable, you can use powerline adapters.