Funds stuck in ledger need help

As of the last few days I have been having issues sending ZEC from my Ledger. Whenever I try to send coins I get an error " Ledger device internal error, please report (0x6f01)"

I went into the advanced settings under coin control options and messed around in there. I was able to select specific addresses and change the coin selection strategy and this allowed me to withdraw about half of my balance… but half of it is still stuck on the ledger no matter what I do.

has anyone else had this issue?

I do have an issue where my funds are stuck in the Ledger wallet, but it does not appear to be the same. You issue seem documented in the Ledger documentation, have you taken a look at it already?

Yes thank you very much… I read the link and they have the info on the issue right there.

It seems the error happens when trying to send a deshielded ZEC balance to a transparent address.
That makes sense as my entire Ledger balance is deshielded… what can I do to get access to my coins… the method they explained there only worked for about half of the balance.

Not sure if you’ll be able to find help here, hopefully you will find a way though. I would suggest to open a ticket with Ledger asap, as they can take a while to answer anything.

1 Like

I just had a chat with them live on their website through their chat box thing. Very impressive I was able to speak with someone that fast. They said basically they are aware of the issue and the only way around it is to put my seed into another wallet to get access to my coins… or wait until they push out an update for shielded transactions.


1 Like

This situation really sucks.

I’m in the same situation but worse. I was about to transfer my ZECs to a new Ledger because I couldn’t find the mnemonic from the older one, and then I realized those tokens were, and still are, stuck.

That is unfortunate, but this is THE hardware wallet issue weve been facing; any funds sent from unrecognizable addresses break the wallet. (IMHO, given the history of trouble with them and the promise of improvement only bolstering sapling, I would avoid ‘HW’ wallets in favor of an offline cold wallet.)

What about the Ywallet ledger app? Is that compatible with your device?

1 Like

I ended up in the same spot about a year ago. Ironically it was because an exchange I used offered shielded withdrawals and when combined with this software issue on the device, created the current situation to the entirety of my holdings.

I’m currently looking through the YWallet docs

and it has a way to side load the app you need to send your funds out. I tried loading YWallet on windows and then using the “import from ledger” function but with a nano x it didn’t seem to work. So the other option is to order a nano s plus, restore the seed phrase to the nano s plus, and then side load an application that will allow you to send the funds per the link.


I will research this further thanks so much for the help.

What about a Trezor? Wouldnt restoring my wallet to Trezor work or would it have the same issue?

1 Like

In theory I don’t see why it wouldn’t work. However, I have never done this myself. Please let us know the outcome if you try.

Import the seed phrase from ledger to hot wallet such as y wallet and zingo! wallet, then the balance will be shown and able to do transaction with the fund. I experienced the same for once, that was frustrated.


Just imported to a new Trezor Model T and worked like a charm! Thanks for the help guys!