Good and cheap mainboard with 1150 socket for 6 GPUs

Hei,

I do have 2 ASROCK H81 Pro BTC mainboards, but I am running into problems using my Sapphire Radeon RX 470 Nitro+ cards. Both board refuse to clean start with more than 2 cards connected via raiser. BIOS is the latest 2.30, iGPU disabled etc. ...

PCIE Gen1 setting works better than Gen2; the machines POST more often in Gen1. Ether setting, I often have to reset the machine to get it POSTing.

I checked the GPUs and raisers yesterday, all are working. I am about to test another board/chipset this afternoon. It has just 3 (or 4?) PCIE slots, but I have to see if the boards are fishy.

So if the H81 boards won't work, I need 2 new boards that are proofen to work with 6x RX470 cards. Thing is, after buying 12 of those GPUs + equipment, I am low on budget right now. :blush:

Which board can yoy guys recommend? I know, Google tells me some, but most of those topics are quite old. :stuck_out_tongue:

I have 9 of those boards with no issues at all... did you plug in the molex into the board? Which risers you using? What power supply

1 Like

Yes molex plugged in.

Molex powered USB raisers.
You can read more about my problems with the setup here:

Which slot is second card in?

I tried the second below the main PCIE slot yesterday.
But in the last 8 days I tried several combinations.

All cards, 2 cards, 3, 4, 5. Swapped raisers and GPUs. Swapped memory, swapped GPU.... etc.

Oh and PSUs are CoolerMaster G750M.
2 PSUs per rig. One PSU for all molex connections, board, HDD and 3 GPUs. The 2nd PSU for the 3 last cards. Spliced PW_ON# from the 2nd PSU to the first PSU to start them simultaneous. But the last 2 days I have only been working with 1 PSU and up to 4 cards.

Maybe they need dummy plugs in the connectors of video card? it's not uncommon

Oh that is new to me. :blush:
But that sounds sensible.

I'll look into that!

Let me know how it goes

Got 12 DVI->VGA Adapters.
Then I found out that my GPUs do not have analogue ports.

:bread:

I tested the other board, and that one seems to work. BUT!
Read here:

Hmmmm don't know if bad drivers or cards or cables

Each GPU works with each raiser in the main PCIE slot. Therefore I say the cards and the cables are fine. I guess. :joy:

Sounds exactly what my problem was I just had, but when I used power risers it worked.... But you have those.... hmmmmmmmmmmmmm

Try auto detect instead of GEN1 or GEN2

I think you are overcomplicating things.

Setup one rig without GPU. Turn it on and check if it works in windows.

Restart, disable onboard graphics (set display to pci-e/gpu)

Turn it off.

Add one GPU directly to the PCI-E slot turn it on again. Check if it installs the drivers in windows.

Turn off rig.

Add the one GPU with 1 USB powered riser. Turn on rig check if it works.

Turn off rig, add second GPU with USB riser...

Rinse repeat.

1 Like

I was there before.

It works with one card in the main PCIE slot in the H81 mainboard.
But when I add another card to a x1 slot, it stops working.

In the Z77 board it is kind of the same.
1 card in the main PCIE works
2 cards each in one th the big PCIE slots works.
But when I add a card to x1 slot, it does not anymore.

Just tried on the Z77 with a third card.

Google your board and number of GPUs it might be specific slots needed to be used.

Might not be related, but I did read that some boards / risers need a link put in for graphics cards to work correctly in the 1x slot.
http://www.gobitgo.com/articles/1001/How-To-Correctly-Use-and-Install-PCI-E-Riser-Cables/
see there about half way down the page.

1 Like

I'll try this when I come home! :slight_smile:

Thanks for the link!

1 Like

I'm curious too!!! Keep me poosted