Problems booting ASRock H81 Pro BTC. No POST, 9 out of 10 starts

Hei there!

I just got equipment for 2 mining rigs yesterday evening. Used some time to mock up my first setup to play around with. The systems are build up of 12x Sapphire RX470 Nitro+ OC 4GB, 2x ASRock H81 Pro BTC, 4x CoolerMaster G750M....

More about the system here:

And here:


Now the problem is that the mainboard won't POST, well sometimes!? I stripped the setup down again to the mainboard and 1 RAM stick, that's it. Then I got into the BIOS. I updated the BIOS to the latest version, enabled internal GPU as primary device and enabled Multi GPU.

The board did restart normally. Then I installed one GPU after another, testing the board after each card. But sometimes the screen just stayed black, even without adding or removing a GPU. After a few resets and power-offs and -ons it would boot with all 6 GPUs. So I was able to install Xubuntu 16.04 followed by a few restarts, and compile zogminer.

After another restart the screen stayed black again. No POST what so ever.

So I removed all GPUs again, but no POST. After a CMOS clear it started again. But as soon as I used just 1 GPU the board didn't post again. After another few resets and power-offs and -ons it started again. But I had to restart the machine again after installing the AMD SDK. And the screen didn't turn on another time. And now my reset & power-off/on trick won't work anymore. :frowning:


Any ideas on that or how to troubleshoot? Did not have time yet to check the 2nd board. Will give that a try later today.

greetings!

Have you tried disabling the onboard GPU and using the GPU attached to the 16x slot with bios set to gen2 ?

Does it beep ? :smiley:

No speaker, no beep. :smiley:

But I'll try that later! Just red something about powered raisers in combination with the H81 BTC. This board comes with its standalone power supply for the PCI slots. So there is no need for additional powered raisers. I hope I did not fry the board. :cry:

Have to redo all cablemanagement this evening.

Look to the lane next to your powersupply connection on the motherboard, if you did not use risers and not the molex connection on the motherboard it should be smokes.

I only use H81 Pro BTC because they are so easy to handle. Use 3x PCI unpowered vrisers and 3x USB power risers and am not using the molex connections on the motherboard.

Gonna use same mobo, order didn't received yet. In the manual stands the powersupply for gpu is only for 3 cards! I will plug power supply into each riser ....

Okay, small update. Nothing went up in flames yet. :tada:

I got the system to boot again, I had to change the order in which the cards are powered by the PSUs. Also I modded the PSUs to start synchronously.

Here is my current setup:

  • PSU1 & PSU2 bridged/spliced pin 16 for PS_ON#, bridged CMD

  • PSU1: 24pin + 8pin to mainboard, 2x 4pin molex to mainboard for PCIe power support, harddrive, 6x 4pin molex to risers for GPU 0, 1, 2, 3, 4, 5 and 3x PCIe 6pin to GPU 0, 1 & 2

  • PSU2: PS_ON# pin 16 spliced to PSU1, 3x PCIe 6pin to GPU 0, 1 & 2

The system won't start right away when powered on, but it will post after 2 - 3 resets and boot into Windows 10.
Now I am struggeling with Windows. It will recognize all 6 cards, but only 4 are usable. The Device Manager spits out (Code 43) for 2 of the cards.

I already installed the 6xGPU_mod https://lbr.id.lv/6xgpu_mod/ but this did not solve the problem. :broken_heart:

So now I have to find a workaround here. :confused:

A lot of back and fourth in the last days. Windows 10 -> Win 7, Win 10 pre anniversary. Different drivers, etc. But I can not get more than 2 cards working without Windows getting wonky and crashy. :triumph:

That should just be enough power for 3 RX cards, (check max draw per card ) have you tried starting with just that alone.

1 Like

Well it works now, sort of. I can run all 6 cards with 3 cards per PSU in Windows 10, but 2 cards spit out Code 43.

  • 1 single card works and mines perfectly.
  • 2 cards, and the miner (claymore) stops.
  • Only mining on card 0 works, only mining on card 1 does not. Already switched the cards to 2 new ones to check if the card is bricked, but same behavior.

Have been trying to use Xubuntu 16.04, Xubuntu 14.04 and now Ubuntu 16.04, but I can't get the amdgpu-pro driver installed. Ether it causes a kernel problem (signature verification failed) or it just freezes at the login screen.

Ubuntu 16.04 is running right now with kernel 4.4.0-35 and amdgpu-driver installs with only 1 card in the rig. But mining perfomance is like 10 Sol/s. :sleepy:

I am running out of ideas. :triumph:

Check that onboard Gpu is disabled and set the 16x pcie, if it has one is set to gen2

see if you get more than 10sols

argh wait you're using claymore sorry can't help good luck :smile:

Onboard GPU is isabled. The mainboard wont start with more than 3 GPUs if PCIE is set to AUTO or Gen2. With Gen1 i get roundabout 40 Sol/s with claymore on Win10.

But I give it another shot. :slight_smile:

You get less with claymore due to the dev fee but sounds like you're making some slow progress :slight_smile:

Well i gave up on Windows. Just can't get that to work with more than 1 card.... So I stick to Linux and try to figure out the pronlems there.

Just tested Gen2 for PCIE again. BSOD. The mainboard won't even load up. :bread:

As Ubuntu seemed to work with 1 card and installed amdgpu-pro driver (still with low Sol/s) I added another card to the rig. But the driver crashes upon login.

I guess I try Ubuntu 16.10 now. Kernel 4.8 is supposed to support the GPUs, I think.

Edit//
Nope, Ubuntu 16.10 wint even start the installation. Upon clicking on Install Ubuntu I get a BSOD presentet and the machine freezes.

https://lbr.id.lv/6xgpu_mod/6xGPU_mod.html

Google this mod, it might come in handy ...

You will need to disable ULPS, disable crossfire and play with performance power settings FYI

Hello - I've been mining ETH with 2 of those motherboards for many months. I have seen hundreds of people post to the ethereum mining forum with similar problems. With errors and problems like the ones you are describing - 80% of the time it's caused by bad risers.
Risers are mass made in China and they have very little or no quality control. I have bought probably 2 x as many as I am using because they often don't work. I have a friend who ordered a bag of 10 of them and 7 of the 10 were faulty when he got them
What kind of risers are you using? The best kind are the USB powered risers. Make sure if you are using powered risers - with the molex power plug - that you power ALL the risers with 1st PSU, i.e the PSU that is powering the motherboard. Only use the 2nd PSU for the 6/8 pin GPU power.
Also from what I have read, 6 GPU systems are very commonly unstable. Most big scale mining farms use 4 or 5 GPU systems. I am using 2 x 5 GPU systems with all USB risers and they are fine, but like I said I have probably bought 20 risers to find 10 good ones.
You might try some searching through the ethereum forum mining section because it has been dominated by people who mine with RX cards for the last couple of months.

I am using those:

They look fine at first glance, but the soderings are not that good. Maybe I try resodering them.
I am using a default molex connector from the PSU to power them, as the power cable on the raiser is a bit wonky.

I connected all raisers to PSU1, as well as the first 3 GPUs with 6pin. The 2nd PSU is connected to the other 3 cards and the PS_ON# signal of the mainboard.

Well if resodering fails, I’ll have to get new ones. :persevere: Chinese crap!

Not that it should make any difference but which version are those risers you have ?

I will check if I can find a version note on the raisers when I get home after work. :slight_smile:

ASROCK H81 Pro BTC, supposed to work with 6 GPUs.

PCI Gen was set to 1, also tried Gen2 before I went to bed, but the driver fails there aswell.
I have not seen any PCI settings regarding the x16, x8 or x4 speed.

I*ll check the DDU later today.

Have been trying Ubuntu, but the amdgpu-pro driver fails to install due to driver signature verification or other funny stuff.

well I am uploading a Ubuntu guide though I may cancel it and upload it while I sleep now as its been taking hours, guess my VPN connection sucks right now.. that might help you with ubuntu installation and AMDGPU-PRO

otherwise yeah try DDU to totally get rid of all the stuff... i read the normal amd/ati driver remover sucks... it seems as though a computer gets used to the GPUs in it, and if some are moved or added, they stop getting recognized, so I have had this a few times happen to me and had to DDU and reinstall... might be connected to your problem, not sure

if you need new risers I can get you good ones, never had a problem with them, never even got one bad one that didnt work.