Having problems when starting zcashd

#1

I'm having issues with -equihashsolver (at least I think it's an issue with that). First of all I've been using zminer to mine in the zmine.io pool, and when I run the command:

./src/zcash-miner -stratum=stratum+tcp://zmine.io:1337 -user=tmGUdN9CE1wNb7znydNHYiyw8VzqmApnLrp -equihashsolver=tromp -genproclimit=-1

to start mining on zmine.io, everything works fine, and tromps solver runs with no issues. However if I try to start mining alone using:

./src/zcashd -daemon -equihashsolver

It doesn't successfully start the server, and it throws this error:

zcashd: miner.cpp:461: void BitcoinMiner(CWallet*): Assertion 'solver == "tromp" || solver == "default"' failed.

Also, if I run:

./src/zcashd -daemon

everything works fine. I'm not sure what is going on here, any of you know how to fix this?

#2

Can you copy/paste your zcash.conf file ?

#3

If you do not use -equihashsolver parameter, the solver defaults to default. But if you do use it, you need to specify the value, either default or tromp.

#4

@JanKalin Ohhhh wow. Stupid mistake on my part, thanks!