I began mining. I have a question

./src/zcash-cli getinfo
blocks in the obtained information, and

./src/zcash-cli listtransactions
The blocks in the obtained information does not match, is it normal?

The listtransactions command will list all coins you have found, including immature coins. Look for the line that says spendable and the line that says #of confirmations.

A coin is only considered spendable after 100 confirmations and that is the amount you see when you run the getinfo command.

Ah, thanks for the heads up - I only just realised how long this thread is!

Hi guys,

This is my first attempt at mining anything and I'm pretty noob at this stuff, but I figured I would be able to copy and paste the commands easily enough... seems I was wrong about that :sweat_smile:

Anyway, I've installed Debian on Parallels for Mac and went into the terminal to paste the first command in the Public Alpha Guide to install...

sudo apt-get install \
    build-essential pkg-config libgtest-dev libc6-dev m4 \
    g++-multilib autoconf libtool ncurses-dev unzip git python \
    zlib1g-dev wget bsdmainutils

and got back the line...

bash: sudo: command not found

Does anyone know what might be causing this? Is it asking for admin rights? I'm the only user I set up when installing Ubuntu so I'm a bit lost here.

Thanks for any help!

Take out the slashes and combine the lines into one.

Thanks for the reply.

I just tried entering the following into the terminal:

sudo apt-get install build-essential pkg-config libgtest-dev libc6-dev m4 g++-multilib autoconf libtool ncurses-dev unzip git python zlib1g-dev wget bsdmainutils

but got the same bash: sudo: command not found back.

Did you get this working?

On Ubuntu/Debian systems

sudo apt-get install \
build-essential pkg-config libgtest-dev libc6-dev m4 \
g++-multilib autoconf libtool ncurses-dev unzip git python \
zlib1g-dev wget bsdmainutils

To make it easier, simply highlight the entire text field and CTRL+C to copy and in the terminal you can CTRL+ SHIFT+V to paste. In the terminal CTRL+C means cancel and should not be used, so you can use CTRL+SHIFT+C or V when copying and pasting in the terminal.

Hi Shawn,

Thanks for taking the time to reply.

I'm still not getting anywhere. I'm starting to think it's a different problem than just entering the wrong commands into the terminal. I might try installing Ubuntu instead, and see if that changes anything. Thanks for your help!

I have personally only used Ubuntu and Lubuntu for Zcash installs and have not had any problems, so hopefully that works for you.

Thanks mate, will hopefully have things up and running soon :slight_smile:

Debian seems to not have sudo installed by default.

Try using this command:
su

This will switch you to the root user.
if you succeeded, then type the following:
apt-get install sudo

then edit the sudoers file:
nano /etc/sudoers

add your current user (the non root user) below the line "%sudo ALL=(ALL:ALL) ALL"
like this:
yourusernamehere ALL=(ALL:ALL) ALL

save and exit

if this didn't work, then simply, remove debian and install ubuntu :slight_smile:

1 Like

Thanks for the help man... but I'm afraid I've already uninstalled it and am just copying the Ubuntu .iso onto a USB as we speak! :smiley:

Hopefully if someone else is having the same problem they'll find your answer!

Thank you.
getinfo ,return ""blocks" : 456,"
but listtransactions , return all information are ""blockindex" : 0,"
IS it normal ?

Hi guys,

I'm just setting up zcash on Ubuntu, and had hit a wall. Everything went fine until the Testing section. It says in the Public Alpha Guide that the tests need 8GB of memory to run, and as I only have 6GB committed to running Ubuntu (on Parallels for Mac), I wasn't surprised when the tests failed so tried moving onto the next stage of running zcash.

After running ./src/zcashd -daemon

I get the following error:

Zcash server starting
jackwatson@ubuntu:~/zcash$ 

************************
EXCEPTION: St13runtime_error       
could not load param file at /home/jackwatson/.zcash-params/z7-verifying.key       
bitcoin in AppInit()

That's where I'm at. I'm not sure if the above error is related to whatever caused the tests to fail, or because I made a mistake in the zcash.conf file (although I think that's fine).

Any help would be much appreciated :fist:

Do you have a zcash.conf file?

This comment might also be relevant - https://forum.zcashcommunity.com/t/botched-attempt-from-fresh-install/1029/2

1 Like

As @Voluntary mentioned: double check the contents and location of your zcash.conf file.

The zcash.conf file needs to be inside the .zcash folder, often I have to make the .zcash folder manually.

And as a side note: Linux treats any folder name starting with a period . as a hidden file. You can hit CTRL+H when looking inside any directory to see the hidden files.

Thanks guys.

I can't see the .zcash folder in username/ but it's there because I can't create a new folder with the same name in that location.

Similarly when I run mkdir .zcash I get mkdir: cannot create directory '.zcash': File exists back

But when I run .zcash/zcash.conf I get back bash: .zcash/zcash.conf: No such file or directory

Edit: found the hidden .zcash folder with CTRL+H and added the zcash.conf file to it with the following:

testnet=1
addnode=alphatestnet.z.cash
rpcuser=rpcusername
rpcpassword=rpcpassword
gen=1
genproclimit=3

ran ./src/zcashd -daemon

and it now says Zcash server starting. Progress!

Thanks very much for the help guys.

"Zcash server starting" with gen=1 in your zcash.conf means you are officially mining :smile:

That's awesome, it feels good! I didn't even realise that wasn't the last step :sweat_smile: thanks again for the help mate

Why after command getinfo I see new adress?
But amount correct…
Which adress my wallet?