Ledger X error in withdrawing Zcash?

Hello,

What is another option for withdrawing Zcash from Ledger as I am getting the following error:
Ledger Nano X - “Operation denied on device”
Ledger Nano S - "Transaction may have failed’

First step: I would check that your Ledger hardware has the lastest firmware: for Zcash and Bitcoin.

ok thank you

Do you know if there is a way to use a 3rd party app or wallet to import the private key from Ledger to be able to withdraw it off the blockchain as a back up plan?

I just used the BIP tool to get the Private Key and then tried to import the key into ZEC Lite wallet and got the following error:

“The input key was not recognized as either a sapling spending key or a sapling viewing key”

And ideas or solutions? Thanks again.

ZecWallet lite does not support importing private keys, only seed phrase. If you want to import private keys you will need ZecWallet Fullnode.

Note: ZecWallet Fullnode will take much longer to download and verify Zcash 29GB blockchain.

Just one minor clarification: Zecwallet Lite does indeed support importing both Sapling private keys and Sapling viewing keys (since July), but not private keys for transparent addresses.

@deepside10, you are getting that error because Zecwallet Lite is expecting a Sapling private key (or viewing key) but you are entering a private key for a transparent address. Try importing your private key into Guarda Wallet (the multi-coin Guarda Wallet, not the special shielded wallet from Guarda). You will have access to your coins within seconds.

(Addendum: Before you try Guarda, note the recent security incident that occurred 2 days ago: https://guarda.com/blog/security-incident-on-december-30-2020/.)

(Addendum II: Exporting your private key from Ledger into another wallet defeats most of the security benefits of the hardware wallet, so it’s best to try what @Shawn recommended first. If you haven’t updated your Zcash and Bitcoin on-device Ledger apps (and possibly firmware) since November, that is almost certainly the problem, as older versions of the on-device Zcash app won’t be able to sign transactions due to the Canopy upgrade.)

4 Likes

Thank you for your responses and time.

I don’t see where to update the Ledger Firmware.

My current ZEC version is 1.4.7
Ledger Live 2.0.0
Firmware is 1.2.4-1
OS is Windows 10

I tried exporting the private keys for ZEC using the https://github.com/iancoleman/bip39 tool
and importing them into the Guarda Multi-Currency Wallet and it says Private Key Invalid

There are 2 private keys that both begin with: xprv9z

Any other options?

Thanks again.

Try in Jaxx Liberty wallet.

Menu -> Tools -> Paper Wallet Import

Thank you for the idea about using the Jaxx Liberty wallet.

I tried to import each of the following Public and Private Keys into the Jaxx Liberty Paper Wallet and they all say Private Key Invalid.

Account Extended Private Key
Account Extended Public Key
BIP32 Extended Private Key
BIP39 Seed
BIP32 Root Key
BIP32 Extended Public Key

Again, I retrieved all these by using the https://github.com/iancoleman/bip39 tool.

Any other options or solutions?

Thank you all for assisting me with this. I appreciate you all very much.