Monitor not displaying anything, not sure if the RIG BOOTS - ready to pay, if someone helps me start

Hi All
Please help me, I am really frustrated. I have RX570 Sapphire, I tried connecting the Monitor to the GPU. Only 1 GPU.
On switching the RIG ON:

Motherboard FAN works
GPU Light turns ON
GPU Fan does not rotate
Nothing gets displayed on the Monitor, it is in Sleep Mode and does not get activated
I tried with UBUNTU bootable USB

It seems that something is wrong - as it does not boot up. May be the keyboard is not getting detected, or only part of the MotherBoard is working.

Please help me, also find the photos attached as per the screen shot.

Should I try with Windows loader ? For the past 1 month I am struggling.

Thank you very much, I am ready to pay as well in case the Rig starts working.


Have you tried it directly on the motherboard as well and not on the riser and have you tried onboard graphics? I had a similar problem and once connected to onboard and changed everything in the bios to legacy my Linux started to work but you have to make onboard graphics as default and not auto

The picture doest focus on power switch cable but i think it should be rotated by 90 degree.

Yes check the power connections, had a similiar problem, was a loose connection to one of the PS’s

First of all I would unplug the riser and try the onboard graphics. If that works, you know, that your problem is located at the riser or the graphics card.
I had a similar problem and the problem in my case was the riser. I changed the riser and everything was working fine.

Good luck!

1 Like

I dont’ even think it’s possible to use GPU as display through a riser, since the riser uses only 1 channel and not all 16… right?

Best solution is on board graphics, if monitor doesn’t turn on from integrated then put GPU in MB and then set bios to integrated (after reboot display from GPU won’t “work” any more)

It’s possible. I tried it and there’s no problem to connect a display to a graphics card which is connected through a riser.

1 Like

Hi All Thanks for your inputs - I tried the below:

1st trial:: Connected the HDMI to GPU - to HDMI 1 - did not get any response.
---- GPU lights are ON but GPU fan does not rotate
---- Keyboard - when I tried to press CAPS LOCK ON - there is no light on that too, so not sure if Keyboard too is working.

2nd Trial: Removed the GPU completely, connected the monitor to MotherBoard
---- No response on Monitor
---- No keyboard light, when I tried CAPS ON
---- Even Mouse does not have the “Red Light”

In the USB - I downloaded Windows10 ISO, the USB has a .exe file.
Am I copying the wrong ISO or doing it the wrong way, downloaded Windows 10 from microsoft site, then used the Windows 7 Download tool to copy to USB.

Pics are as shown bellow.

Is anything wrong with the motherboard ? if it was then CPU fan also would not rotate.

I have another old desktop, should I try with that mother board ?

Your motherboard has four power connectors, but as far as I can see you connected only one of them (the ATX Cable 24 pin). You should also connect the EPS/ATX12V (8 pin) connector for the CPU and the two Molex (4 pin) cables and try it again.


@shark1 is correct. You haven’t connected the CPU power connector (marked either CPU1 or 2 on your PSU) to the 8-pin connector on your motherboard.

Thanks a lot. Let me connect all and try again.

Okay, please let us know if it’s working.

HI All I bought new CPU compatible to H81 Pro BTC motherboard and tried again.
This time the changes I observed:

connected all 4 motherboard connections to Power supply
GPU light and FAN were working ( earlier FAN was not rotating - now started!
CPU fan also working
power supply fan is working
Still I do not see anything on monitor.

  • tried direct connection of Monitor to GPU in both slots HDM1 and HDMI2
  • tried direct connection of Monitor to Motherboard also

could the issue be due to the bootable disk which I am using ?
please help me

should I buy new motherboard - is the motherboard not good ?


I would remove everything USB and see if it boots. I was using a wireless keyboard and had issues.

Riser could also be a possibility. So plug that in directly to the board and see what happens.

In most cases its trying to boot to USB first.

Bare bones it…

remove the gpu, connect to the onboard vga and boot… does it?

do you hear two to three beeps when it starts? if not then it’s not posting. Bad ram, bad cpu

if yes, then can you get to the bio’s screen? if yes

do you have it set to boot from your usb in the bio’s? if yes

and it will not boot into the o/s then you have a bad drive or bad o/s installation

Yeah at this point gotta see if it’ll POST or not. Could try reseating the ram of changing slots. Make sure the heat sync is secure to the mobo and not loose. Without adequate pressure the CPU will instantly overheat.

I’ve not worked with that ASRock board before but I don’t think you need all those PSU connections. Believe the MOLEX is for SLI/Xfire according to the manual. Should be good to boot with an 8 pin connection and ur 24 pin.

Monitor and Cable working? Have you tried on another PC with low resolution (BIOS)?

Press “Delete” Key when starting.

Before it needs your boot disc it should show something and go into Bios before you check your boot drive.

Yes… Monitor and cable are fine, tested that on other pc.

DELETE also is not working…

Remove the graphics card, plug in the HDMI cable directly to the motherboard and check if you can see the BIOS screen. It’s important to remove the graphics card first, because otherwise the motherboard will automatically use the PCIE device if you haven’t changed your BIOS settings to “always use onboard graphics”.

F11 sometimes, 20char