Solved: MSI Z170A SLI PLUS - 1 to 6 GPU Problem

Hello,
I'm just started building a mining rig with this components:

  • Motherboard: MSI Z170 SLI PLUS
  • GPUs: 6x GigaByte GeForce GTX 1070 Windforce OC
  • Riser cards and cables 16x to 1x

Everything works fine with onboard graphic and with one directly connected GPU.
If I remove the GPU and connect it with a risercard and cable the red led on the motherboard is active and nothing happend - only a black screen and no green Num led on the keyboard.

What I already tried:

  • Flashing Bios and Installing the latest release
  • Installing Windows 10 on a UEFI/ GPT partition - doing all Windows updates
  • Connecting one GPU directly to the board and installing the Nvidia drivers
  • Changing in the BIOS ‘PEG0’ and ‘PEG1’ values to ‘Gen1’ and Set ‘Above 4G Decoding’ to ‘Enabled’
  • I also tried different ports with different risers and different cards - always the same will happend: Black screen and red led on the motherboard.
  • I also disabled 4G Decoding and tried different ‘PEG0’ and ‘PEG1’ settings - always with the same result.

I read six hours in forums but there seems no solution. Is there another hint? Thank you for helping!

Tobi

Solved: This was an issue with the Power Supply.

How did you resolve it (power supply).

I also have a black screen after enabled 4G Decoding

There was no power on the cables connected directly to the GPUs.
By the way: It's very important to connect not only the Riser cards to the Power Supply, also each Graphic card has to be connected separate to the Power Supply :wink:

Have you installed the graphic drivers in your operating system?
And the latest BIOS update?
Also change in the BIOS ‘PEG0’ and ‘PEG1’ values to ‘Gen1’ - if it's not, it causes a black screen too.

Try to connect from another device witth e.g. TeamViewer - perhaps you can connect and see an error message.

1 Like

Hello. how are you? How did u solve the problem??

There was no power on the cables connected directly to the GPUs.
See also my reply: https://forum.zcashcommunity.com/t/solved-msi-z170a-sli-plus-1-to-6-gpu-problem/17578/4?u=miningstarter

The cables have power. I can mine with 4 GPUs.

I have black screen when I change BIOS BIOS ‘PEG0’ and ‘PEG1’ to ‘Gen1’ and enabled 4G decoding.

Are all 6 GPUs working?

I have the same board with 6x 1070s (Asus 1070 strix oc). All are detected, but 2 of the 6 have an error: code 12 - This device cannot find enough free resources that it can use. Does anyone know how this can be fixed? I've also disabled and audio, serial i/o, but the issue persists. It also happens with 5 GPUS, but when there are only 4 it works fine.

CPU - G4400
Mobo - MSI Z170a SLI Plus
PSU - 2x EVGA 750w G3
RAM - 4GB DDR4 2133mhz

Yes 6 GPUs working without any problem. I had to install the drivers in Win 10 for the fifth and the sixth GPU separately.
That means I installed the Nvidia driver only with one connected GPU. The following three (two to four) were detected automtically. The fifth and the sixth GPU were shown as "unkown device" in the Devicemanager. There I installed the drivers (automatically) and after restarting Windows all 6 GPUs works fine.

The Message "This device cannot find enough free resources" is only shown, if in the BIOS ‘PEG0’ and ‘PEG1’ values are unequal ‘Gen1’. That was also a problem in my case :wink:

1 Like

Have you installed the latest version of the BIOS?
What happens, if you change only ‘PEG0’ and ‘PEG1’ to ‘Gen1’ without enabling 4G decoding?

Hmm, I also initially installed the driver with only 1 GPU (followed what you did). Added 2,3 and 4 - detected and installed (automatically) with no issues. Then added 5 and 6, detected and installed (automatically) but with the error code. :confused:

In the BIOS PEG0 and PEG1 values are set to ‘Gen1’ And 4G decoding is enabled.

Yes, I've got the latest Bios. I'll try and change only ‘PEG0’ and ‘PEG1’ to ‘Gen1’ without enabling 4G decoding and see what happens.

It works fine with the latest bios. I only tried with 4GPUs.

And when I changed 4G decoding to enabled with 1 GPU I can't launched W10

I got it working! :slight_smile: I ended up re-flashing the bios and for whatever reason, it worked this time! With the exact same steps I had done before.

@etrixone not sure why it won't launch for you, but make sure you follow the initial instructions. Especially:

  • Flashing Bios and Installing the latest release
  • Installing Windows 10 on a UEFI/ GPT partition - doing all Windows updates

I also did this in the BIOS:

Settings > Advanced > Windows OS Configuration
* Windows 8.1 / 10 = “Enabled
* Windows 7 = Disabled
* MSI Fast Boot = Disabled
* Fast Boot = Disabled

regarding to the VGA driver installation issue.
after install all six card with riser , do I need install VGA driver again???

No, you don't have to install the drivers again. Check only in the Device manager, if there' re one or more cards missing in the section Graphiccards and shown in the section Other devices. Only in this case you have to do a driver setup for this device. But not in general!

Another hint:
Windows 10 takes a time to recognize and installing a new device. The following best practice worked for me:

  • Connecting only one card and installing the drivers - you have to be patient with WIN 10. It can take several minutes. Open the device manager and take a look at the Graphic section. Only if NVIDIA GeForce GTX 1070 is shown there, driver installation is finished. Wait this time.
  • At this point I change the BIOS settings ‘PEG0’ and ‘PEG1’ values to ‘Gen1’ and Set ‘Above 4G Decoding’ to ‘Enabled’
  • Restarting and check if everything works fine.
  • After this I connect the next three cards, Open the device manager and take a look at the Graphic section and waiting until NVIDIA GeForce GTX 1070 is shown for all four cards.
  • Connecting the last two cards - restarting and it's done
1 Like

Hi, I'm new to the forum, just planned to start mining Zcash on the same platform, using MSI Z170-A Plus and 6 x MSI GTX 1080 ti FE that i found cheap before the actual rocket launched prices off 1070 and everything else.

Based on BIOS updates from MSI for all the z170 and z270 boards, I decided to go with the mentioned model, because of the price and VGA onboard connection, which will be used as primary video for monitoring, hooked to a KVM Switch.

I suppose that onboard CPU video could be enable as primary video and then use 6 x GTX 1080 ti without any video connections.

I'm waiting for PSUs Arrival, will be using EVGA 1000GQ plus 850GQ. A dual setup, because of the wattage on this video cards, approx 250w + per card.

I'll comment here if everything goes as spected, thanks for your tips @MiningStarter an everyone who commented a possible workaround for this motherboard.

Any advice or suggestions will be appreciated.

Happy Mining and Moneymaking for all.

@MiningStarter I'm having an issue with the same board and GPU combination...I can't get any of the GPU's to show up without having them plugged directly into the board. They're not under Device Manager; rather, they're a generic System Device.

I updated the BIOS to the latest version 1.7, performed a clean installation of Windows 10 in UEFI, as well as followed the instructions above regarding 4G encoding and setting PEG0 and PEG1 to Gen1. I've also made sure that I am using HDMI and NOT the onboard Intel GPU.

After the clean install, I wanted to see if I could directly plug them in and Windows recognized two. I couldn't get past two, even with the USB-powered risers. Any assistance would be greatly appreciated! I have been scouring the net for days without any progress...

MSI Z170A
Intel i3-6100T processor @ 3.2GHz
8GB Crucial DDR4
6x PCI-E1X TO 16X USB Risers
6x EVGA Nvidia GeForce 1070 GTX FTW GPU
1500W Enermax MaxREVO PSU

I don't mind doing a clean re-install of everything, so long as I can further than what I did last time. Hopefully, I can get some very clear guidance. Many are in the same situation as I am :slight_smile:

Hi, @waxin_poetic

I think the BIOS version you should use is 1A for this particular Motherboard.

Here is the changelog on this Version

Enhanced M.2 Genie function.
- Improved Board Explorer function.
- Improved NVME device compatibility.
- Updated VBIOS and GOP.
- Support multi graphic cards. This is the important update.

Hope to help

@g33km4st3r I went back into my BIOS and realized that I had version 1B. I still went and downgraded the BIOS, but the same results remain. My rig can only detect one out of six GPUs.