New Mining Rig - Mouse, Keyboard & Screen Not working

Hi All

I have just set up new mining rig

I have used MB ASUS LGA 1151 Prime Z270A
Crusial 8GB DDR4 2400 mt/s
Pentium G4560
2 x EVGA PSU 1000 T2
Crusial SSD 120GB

I think everything connected properly, as i have followed a lot of youtube videos

Fans are working, PSUs fans are working, MB LEDs flashing, CPU fan is working, GPU lights are on & when power just switches on, fans spin, but then stop.

From reading this forum, i have tried unplugging GPU from raiser and connected to MB, Still same thing happening, seems like what ever is connected to Motherboard is working and items that are connected to USB slots and that area not working. Is there a switch to turn it on ? am i missing something

Any advice appreciated


2 PSU? Try to use only one.

Yes 2 psus because once ill connect my 6 gpus it will need more power. But yes i will try disconnecting 1 psu.

Tried using one and still the same thing.
Gpu fans not spining, but i have been told they dont have to spin all the time as long as lights are on. So i guess only add ons that not working like mouse keyboard and screen

do you have another gpu to try? with which type of port are you connecting gpu and screen?

Yes i do have more gpus. Gpus connected via raisers but i have tried connecting to motherboard.
MONITOR is connected via adapter. Vga to hdmi.

so you have more then one GPU right now connected to the motherboard?
I pretty sure that your adapter is the point of failure. is you screen only having a vga port?

No i have more gpus. But only 1 is connected. I think only vga. I will double check after work

1 Like

+1 on the adapter likely being the culprit. Had this issue with a build last year. if you have a television or monitor that supports HDMI, go that route to see if it produces a picture.

Just tried on tv and it didnt produce the picture :confused:

try to use another gpu?!

Lights and fan don’t mean power. Your gpu can look alive, but only because of the molex powering the riser. Does it have lights when connected via mobo?

1 Like

Thanks guys for all your input. Its all working now. I just had to put ram in different slot.