PCIe Risers Keep Getting Fried

Greetings mining community,

I am currently running a rig that will mine Ubiq (UBQ). I know that this board may not specifically be a Ubiq mining board, but the equipment is essentially the same except I can still use 2GB graphics cards unlike Ethereum. It’s also worth mentioning Ubiq is an Ethereum fork if you are unfamiliar with it, so it is a dagger-hashimoto/ethash algorithm. I’m using Claymore’s miner.

Before I talk about the problem, I’d like to take the time briefly to thank everyone who reads this post. I have spent many hours figuring this problem out and I am at a point where I do not know exactly how to fix it without some (professional) advice. I don’t want to keep ruining/risking hardware. So thanks in advance everyone! I’ll consider sending tips in your favorite crypto if you can crack the code or offer advice.

The problem:
At some point, sometimes during BIOS, sometimes during boot-up, sometimes during miner startup, the computer screen goes black and the fans on the graphics cards kick into full speed. Like, FULL speed. At least on the main graphics card that is connected to the first x16 slot.

CURRENT System Setup:
-AsRock Z97 Extreme4 (3x PCIe x16 and 3x PCIe x1 ports)
-Various different brands of POWERED risers, they have all been connected via 4-pin molex to SATA power (3 or 4 on the same cord from the power supply)
-850w Raidmax power supply (was pulling 750w from the wall with 5 cards attached at one point (for a good 24 hours), so I know that it is able to run that wattage fine)
-2x 2GB DDR3 RAM sticks
-320GB 5400RPM spin drive
-5x XFX R7 370 2GB graphics cards
-1x DVI cord serving as a dummy plug (that was on issue that I figured out the hard way)

My testing:
I could probably go on for paragraphs about all of the various tests that I ran. I’ll keep it short and simple, though: I have found out that the issue is certainly not software related. I’ve tried various different drivers, operating systems, and miners and this issue seems to be unrelated to any of those factors.

I also know that it is not a hard drive, motherboard, or memory issue. I have tried swapping all of these and the results are the same. As a disclaimer, the motherboard’s 4-pin molex may be causing some power interference with the powered risers.

HERE’S THE MOST IMPORTANT PART: I got the system to run for >24 hours after swapping out some new risers that I bought to some older, working risers that I had. Everything ran swimmingly and I was confident that I had simply ordered some poor quality risers from eBay for cheap and needed to invest in stronger risers. However, these knowingly working risers also failed after about 30 hours of running well, which gives me reason to believe that there is something frying the risers. The problem seems to be one of these things: the graphics cards are killing the risers, the power supply is killing the risers, or the motherboard power interference is killing the risers. To elaborate on the last one, the Z97 Extreme4 has a 4-pin molex next to the PCIe slots that has to be plugged in when more than two PCIe slots are filled. Anyways, something is murdering my PCIe risers (or maybe just the cables are frying somehow?).

Tl;dr: My PCIe risers keep getting murdered by something and I don’t know what it is. I have gotten this rig to work twice using both new and tested risers, and after about 24 hours they will cause the machine to either 1. BSOD or 2. black screen crash and kick the fans to 100000 RPM.

If you have any questions, please please please let me know. I’ve invested a lot of time and money into my rigs, as I’m sure you all have, and I want to get this figured out so I can have a worry-free mining setup once and for all!