Riser x1 -> x16 from x16 slot detection problem

Hi,

I have 3x R9 290x and 2x R9 290 on Z97 GAMING 5 motherboard.
4 of them are connected with riser x1 -> x16 from motherboard x1 slot.

I want to connect 5th with riser x1 -> x16 from motherboard x16 slot, but doesn't work.
I checked riser, electricity, test on other slots evertything and and it works.
I tried to unplug one x1 riser and there are only 3 GPU detected.

I'm using windows 7

Any ideas?

Having the exact same problem!

My post

Windows 7 has a hotfix

https://lbr.id.lv/6xgpu_mod/6xGPU_mod.html

1 Like

It's not (yet) probelm in too much GPUs... that doesnt solve the problem :confused:

Bad riser is my guess

1 Like

No, it works on x1 slot

Same issue on Gaming M5, Windows 10

not sure if it will help but try re-installing your drivers after using DDU to uninstall them
boot up with 1 GPU in, then restart and add another or a couple more and keep going until they are all (hopefully) detected

1 Like

One of two issues here...

  1. A faulty riser. Look at the 1X PCI side and make sure all solder points on the back side of the board are solid looking. Most of the time these are corroded and touching in some instances. Poor QC with most brands found on eBay and Amazon. Try known working ones to verify the card is not at fault.

  2. The gaming 5, at least in my 4 rigs, needs some modification in the bios to allow for up to 7 cards. Due to PCIe lane bandwidth I typically change my PCIe speed settings to Gen1 in bios along with 8x4x4 and 96 latency. Also change graphics mode to from IGP to PEG. But, you will have to plug your monitor into one of the graphics cards. You can also disable on board audio if you want. Try this along with making sure all risers are intact.

On a side note, keep trying different configurations and risers. Sometimes mobos can be finicky and need several reboots to recognize GPUs properly (at least with the way we build out these rigs). With that mobo as well you can check to see if the GPU is being detected via the hardware monitor in the bios. If you dont see it there, windows will not see it either. Once you see it here, if you are having driver issues (error 43, etc) than you can start messing with them.

Use USB riser. Riser with ribbon will not work in 16x slot (on many motherboards).

my advice is never use ribbon risers ..buy the best

1 Like

I solved it.
I pluged riser into 3rd one x16 slot, connect hdmi to monitor and unplug another GPUs and I get picture, boot to windows 7 and add another 4 one on next reboot.

But with win 7 i got 4 gpus and 1 with yellow !.

I try to use mod but didnt work, so I installed win 10 and now work fine everything after few faults with driver on beggining :).

2 Likes

windows 7 is crapy for mining.. i recomend ubuntu 14 or windows 10

1 Like

After few hours ( almost frustrated ) I found your "How to"

I fixed following the point 2.

Thank you very much!

yeah this step is important

Gen1 in bios along with 8x4x4

but using gen2 works fine for me and 7 GPUs

without those 2 changes the board has problems detecing more than 6 for me... thats how I origianlly got 7 GPus to work... that and like a dozen restarts and the right AMD drivers

1 Like

Looks like i have the same issue again, after is added a new XFX 480,

4 x XFX RX480
1 x R9 Fury Windforce

GEN1 and latency 96.

I see all the cards on device manager but only 2 are enabled, on the not working I see this device status :This device cannot find enough free resources that it can use ( code 12 )

Any idea ?

Thanks!

your using a Z170 board? if so the 170 boards are no good for mining, dont use 6th gen boards for mining - hard to get more than 4 to work.

1 Like

Yes, I thought is there a solution ...

Thanks !

yup solution is stick with 4th gen boards :slight_smile:

code 12 can settle ??