RX 480 6th GPU not recognized

Hello,

I have the following setup running:

6x XFX RX 480
Asrock Pro BTC
Windows 8.1
ZCash Claymore v8.0

The problem is, the driver 15.12 is not working for RX 480 anymore, therefore I have to use the newest driver, which at the moment is Crimson 16.11.5.
Five GPUs are working fine, but I can't get the sixth GPU recognized from the system.

I also tried 6xGPU Mod with 16.11.5, 16.9.1 and 16.10.2, but it's not working. It's not an issue related to a clean uninstall, because I've successfully used DDU with a safe restart.

I also tried the drivers 14.4 and 16.1.1, but they are also not able to be installed on the RX 480.
The problem always is, that only the two options "HDMI Audio Driver" and "AMD Install Manager" can be selected, but after clicking the Install button, the installation is finished within a few seconds and ONLY those two items have been installed but no display drivers.

Do you know any fix for getting the sixth GPU to work with AMD RX 480 graphic cards?

Thanks very much in advance.

Kind regards,
- hwlgraka

When you instal AMD driver software first time it will detect every card you add after and instal the necessary drivers that's why u can't see drivers now as software only displays drivers u need and u have already installed GPU drivers, your cards not been detected by motherboard and you should check risers and make sure power supply can handle load,check ur connection and make sure risers are seated proper in board, check out @cryptomined guidelines for trouble shooting

1 Like

Also try windows 10... I had issues with windows 8.1 but windows 10 worked great! What kind of risers? Powered? make sure molex connectors are plugged in as well on MOBO

could be risers or a power connection is not 100% in. otherwise yeah, you could try windows 10 or unbutn 16.04 and see if the problem is still there - ubuntu is free so that might be worth a shot to download and try with amdgpu pro drivers

1 Like

Hello,

thanks for all the hints. I got the sixth GPU working.

It turned out, that I only had to run the 6x GPU mod (https://lbr.id.lv/6xgpu_mod/6xGPU.html) as administrator. Otherwise it doesn't prompt to be executed as administrator but it doesn't modify the registry either.

Hope this is of help for someone else with a similar problem.

Kind regards,
- hwlgraka