Solved: MSI Z170A SLI PLUS - 1 to 6 GPU Problem

@waxin_poetic try to reflash bios A1 and then do a factory reset.

@g33km4st3r I have done so, but I've run out of time for the night...I will continue tomorrow after work...

@g33km4st3rI I woke up early to flash the BIOS to the latest 1B version. I also reset the CMOS by taking out the battery and unplugging, as well as touch the two pins on JBAT1. The blue light came on and I held it for a good 30 seconds. Unfortunately, the result is the same...the two cards are recognizable on the motherboard, but not by plugging in the USB risers.

Hi, what cpu is everyone using? I'm curious to see if there's a trend with what is and isn't working with using the 5th and 6th gpu.

EVGA Nvidia Geforce GTX 1070 FTW edition. I really think that I'm missing a step in this whole set-up. I am going to do a clean re-install of Windows 10. I already made sure that it was installed in UEFI mode, but I'm at a point where I will do anything to get my rig up and running.

@g33km4st3r @wish I performed a clean re-install of Windows 10 in UEFI mode. I had only one 1070 card attached and did NOT use the onboard graphics at all. The main difference that I noticed was that the computer was able to recgonize that I had a GPU plugged in when I installed the Nvidia drivers. I used version 382.53. When I tried to hook one of my USB risers with a GPU attached, it did not capture the card at all. I'm wondering if there is an issue with the USB risers. Does anyone know if there are compatibility issues with USB riser versions and the Z170a motherboard and/or 1070 GPU?

What version USB riders are you using?

Here is the exact model as printed on the board: PCIE164P-NO3 VER007S

I'm using VER006S without a problem.

Here's my working setup again:
* Flashing Bios and Installing the latest release
* Installing Windows 10 Pro on a UEFI/ GPT partition (here's nothing to do - it works out of the box)
* doing all Windows updates
* Connecting only one card with a USB-Riser and installing the drivers - you have to be patient with WIN 10. It can take several minutes. Open the device manager and take a look at the Graphic section. Only if NVIDIA GeForce GTX 1070 is shown there, driver installation is finished. Wait this time.
* Changing in the BIOS ‘PEG0’ and ‘PEG1’ values to ‘Gen1’ and Set ‘Above 4G Decoding’ to ‘Enabled’
* Restarting and check if everything works fine.
* After this I connect the next three cards, Open the device manager and take a look at the Graphic section and waiting until NVIDIA GeForce GTX 1070 is shown for all four cards.
* Connecting the last two cards - restarting and it's done

1 Like

Those steps are very straightforward and I am pretty sure I have done it that way, however, I will try again tonight. It shouldn't matter if I use onboard graphics to set up Windows 10 an then connect a graphics card with a USB riser after completing the Windows 10 setup? I have not had any success with connecting the cards via USB risers. I have a feeling that they're no good and that I'll have to buy another set. However, I do not want to buy another defective set. Where did everyone buy theirs? I'll buy from the same vendor. VER006S @MiningStarter

I bought the cards here: http://www.solution.at/webshop/
But there's only shipping to Europe. At this time there're no more cards available.
Perhaps that image helps: http://i.ebayimg.com/images/g/u7MAAOSwHptY-Pve/s-l1600.jpg

This one seems the same:

1 Like

I will have six of these on order @MiningStarter if I continue to have issues. FWIW, I am running an i3 processor. I don’t think that should be an issue.

@MiningStarter @wish

Here are the steps that I took:

*BIOS firmware updated to version 1B and a factory reset
*Reformatted SSD to GPT and re-installed Windows 10
*Restarted and plugged in one GPU into the PCI-Express slot via USB riser

At this point, I went to Device Manager > Display adapters and saw that there was a 'Generic Microsoft Display Adapter'. I let Windows finish updating.

Almost an hour later, I restarted Windows. I restarted and went into the BIOS and changed the '4G encoding' to 'Yes' and PEG0 and PEG1 from 'Auto' to 'Gen1'. 'UEFI' was already set to 'Yes'

After another restart, I re-visited Device Manager > Display adapters and 'Generic Microsoft Display Adapter' was replaced with 'Intel Series 530 Graphics Adapter'. It did not even pick up anything from the USB riser that I connected.

Even after I followed the instructions to the letter, I have concluded that my USB risers may be defective.

I will be ordering six of the VER006S risers and see if that helps.

How are you powering the risers?

I'm powering them with a SATA ribbon from the PSU.

I'm using VER007C USB risers.

How many risers are you using per ribbon?

With one ribbon, I have tried a single riser, as well as five risers
without success.

i recently switched my z170 board for an z270- way better handling

@wish I will consider that for my next rig.