What gives? "982.508 I/s, 0 Sols/s"


#1

Running NiceHash on my CPUs will get me about 2 sols/s, but using the nvidia card is getting me 0 Sols/s while it shows 982 I/s. Anyone know what causes this?

I'm using Nvidia drivers 21.21.13.7570 on Win 10 64-bit on a GT 730

Thank you in advance for your input.


#2

Anyone ever experienced this?


#3

1 GPU use command -cd 0
2 GPUs use command -cd 0 1


#4

I have one GPU and used -cd 0. What I posted is the result of that. :confused:


#5

Yes, I'm experiencing a similar thing with my GeForce GTX 560 Ti.

C:\zcash>C:\zcash\nheqminer\0.3a\nheqminer.exe -cd 0 -t 0 -b

        ==================== www.nicehash.com ====================
                Equihash CPU&GPU Miner for NiceHash v0.3a
        Thanks to Zcash developers for providing base of the code.
            Special thanks to tromp and xenoncat for providing
                 optimized CPU and CUDA equihash solvers.
        ==================== www.nicehash.com ====================

Setting log level to 2
[2016-10-29 14:15:22.146670][0x00001828]: Using SSE2: YES
[2016-10-29 14:15:22.146670][0x00001828]: Using AVX: YES
[2016-10-29 14:15:22.146670][0x00001828]: Using AVX2: NO
[2016-10-29 14:15:22.179870][0x00001828]: Benchmarking CUDA worker (CUDA-TROMP) GeForce GTX 560 Ti (#0) BLOCKS=56, THREADS=64
[2016-10-29 14:15:22.273470][0x00001828]: Benchmark starting... this may take several minutes, please wait...
[2016-10-29 14:15:22.320270][0x00001828]: Benchmark done!
[2016-10-29 14:15:22.320270][0x00001828]: Total time : 31 ms
[2016-10-29 14:15:22.320270][0x00001828]: Total iterations: 200
[2016-10-29 14:15:22.335870][0x00001828]: Total solutions found: 0
[2016-10-29 14:15:22.335870][0x00001828]: Speed: 6451.61 I/s
[2016-10-29 14:15:22.335870][0x00001828]: Speed: 0 Sols/s

Here are my machine specs:

------------------
System Information
------------------
   Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.160930-0600)
          Processor: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz (4 CPUs), ~3.4GHz
             Memory: 16384MB RAM

---------------
Display Devices
---------------
          Card name: NVIDIA GeForce GTX 560 Ti
     Display Memory: 4050 MB
   Dedicated Memory: 978 MB
      Shared Memory: 3071 MB
     Driver Version: 21.21.13.7563
  Driver Attributes: Final Retail
   Driver Date/Size: 10/22/2016 01:20:53, 17426520 bytes

@nicehashdev, this didn't occur prior to v0.3a of nheqminer. Any thoughts?


#6

This seems an issue with cuda dll.

I found another thread with another cuda issue with a link to this archive : http://www.mediafire.com/file/bq78aa8ofo23x8n/CUDADll%27s.rar

This solved the problem for me.

I have not tried to get back tho version 0.2 of the miner, or used the dll bundled with it.
By the way I got this problem on two mobile gpu : 860m & 960m on windows 10 64bits.


#7

These DLL's are from 0.2b miner (i have uploaded they)


#8

Did your I/s drop dramatically when you switched out the DLLs? Mine was at 900+I/s and now it's 0.68 I/s. However it is working now at 1.39 Sols/s whereas it had 0 before.

The guy on the other thread also recommended downloading the latest CUDA, which I am still working on as it's a 1.2 GB file and going slow. Maybe that will help.


#9

#10

Indeed, that seemed to fix the problem for me, too. Thanks for the suggestion.

However, it was only necessary to copy cuda_tromp.dll from the 0.2 build -- the cudart64_80.dll file was identical across both builds.


#11

@muguthemangler did your I/s drop as mine did?


#12

Are? i didn't mind that, i just copied it and uploaded to mediafire :stuck_out_tongue:


#13

Yes, but they dropped down to the reasonable levels that they were at beforehand. I'm getting approximately 13 I/s, 25 Sols/s on my machine.


#14

Only the number of Sols/s matters


#15

Installing CUDA 8.0 also helped. Now the NVIDIA is getting 0.91 I/s and 1.75 Sols/s

Thanks for all the help!