Why did my Ledger Nano S brick?

Yesterday I tried to send some ZEC to my Gemini account from the Nano S and all the Ledger would do is stay on “preparing transaction” and then eventually time out. I downloaded and installed the latest firmware, removed the Bitcoin wallet app, re-installed the Bitcoin wallet app and then the Zcash app but no change. Still locked at “preparing transaction”. Macbook Air, never any issues before.

This morning I tried it on a new computer and was able to send two transactions to Gemini, a test of .15 ZEC and later another .30 ZEC and both went through fine. Windows 10.

Once they were confirmed I thought I was golden and tried to send the entire balance to Gemini…about 6 ZEC. Same thing started again…locking at “preparing transaction”.

I tried changing the amount to send from 6 ZEC to 0.15 and that didn’t work either. Back to square one

I’ve used this Nano for about 10 months with zero issues (sending to Kraken) and this behavior is getting me a little nervous.

Another possibly related very weird thing is the balance the Ledger shows is way off of the actual balance per Blockexplorer. The discrepency has been going on for a couple of months but usually fixes itself after a few syncs. The sync isn’t working now either no matter how many times I try it.

This is the first time I’ve tried sending any coins out of the Nano in just over a month.

Any ideas on how to get the rest of my coins to another more reliable wallet?

TIA

How many inputs were in the 6zec TX? do you have the TX ID?

If there were hundreds of inputs it’s going to take awhile to be mined by some pool

Thanks for the reply but not sure I follow you…

The Nano freezes at “preparing transaction” and then bricks, with the device never actually sending anything to the blockchain to be mined. Am I missing something?

To answer your question, there are <40 inputs that generated those 6+ ZEC that I’m trying to output to Gemini. Most were 0.250+ and none were under 0.150 ZEC

I have been having problems viewing my balance and last transaction on the Ledger as well, but have no problems sending out yet. It isn’t the Ledger itself but the software because I have 2 Ledgers and it happened on both of them on different PC’s. Make a support ticket with Ledger. It is making me nervous as well and wonder if I should send it all to a different wallet.

Appreciate the response.

Note that my Ledger started reporting the wrong balances for a few weeks before it bricked. If I continually refreshed, (clicking the circle in upper right corner) it would eventually reconcile with Block Explorer. It slowly became worse and worse.

Now it won’t reconcile at all or output any funds.

I did create a support ticket and sent in my log files…fingers crossed.

I think it has to be their servers because I have 2 ledgers with the same seed on them and they both do it. I only use 1 of them routinely so I don’t think it could be the ledger itself. Yet their server status says the servers are fine.

http://status.ledger.fr/?utm_source=zendesk%20main%20page&utm_medium=top%20faq

I think they can recover your ZEC from the ledger though if it comes to that.

Could it be from a overwinter upgrade? Also. If I keep refreshing it will disappear and reappear. It is only the last transaction though. Once I deposit more into the wallet the previous transaction is fine. When I refresh the last transaction it will say 1 confirmation even though there are thousands.

I may send my ZEC to 2 or 3 different wallets until this is figured out. Is the Gemini wallet insured and secure?

I was contacted by Ledger support and told that their ZEC servers were out of sync and would be reset, so your idea that it might be software looks to be correct. Whew!

This afternoon I connected and the Nano sync’d up quickly and matched what is shown on Block Explorer.

Next, I attempted to send about 6+ ZEC to Gemini Exchange and it went through in a matter of seconds, just like it used to do a month ago.

So for now, I am experiencing no problems at all! Hope this was just a temporary thing. I don’t really like keeping my ZEC on an exchange but for now I’m ok with it. If over the next week or so I have no further issues with the Nano S I’ll pull them back.

Thinking of setting up WinZEC wallet as a backup.

Amandine (Ledger Customer Service)

Jun 4, 14:29 CEST
Hello,

Thank you for contacting Ledger support.

We are very sorry to learn that you are experiencing this issue with ZEC.

Our Zcash (ZEC) explorers are out of sync. We have relaunched a synchronisation that should be over around 3PM CET

3 Likes

That is good news! I wonder why the status page doesn’t tell us that? Please keep us updated if everything is ok when you pull them back.

1 Like