Zcash full node funds not showing

Latest Zecwallet full node, fully synced, imported shielded private key, performed rescan, but no funds? What to do next?

CC @adityapk00

What is the current status in the lower lefthand corner of Zecwallet Fullnode?
Have you tried restarting the program?

If these have already been done, you will need to check the debug.log file for clues to what is going on with the program.

The file should be located at “%AppData%\Zcash\debug.log”.

You are looking for results that look like the following:

Note on rescan speed (18.55 minutes):
Your performance will be different based on your hardware capabilities.
The rescan in the image above was done on the following hardware/software:

Windows 10 2004 x64
Intel Xeon E5-1650 V3 (Haswell-EP)
NVMe PCIe SSD
zcashd 3.1.0
The synced database used included transaction index.
If there was a problem, the log file would show some error or activity showing the problem around the time you import the key.

Did not have that line AddToWallet…

Hello,

Check to see if the key you imported is listed in the text box when you choose File Menu -> Export All Private Keys.

If it is and the rescan completed, then there were no transactions found associated with the private key(s) in your wallet. The “AddToWallet <New | Update>” information only shows up in the log files when a transaction is found while rescanning or updating the blockchain db.

If you are sure the private key has transactions (funds were sent to it at least once), then you can try re-indexing and rescanning.

  1. Reindex the blockchain.
    This will use your CPU to verify all blocks from 0 to current and attempt to repair any damaged data found. This will generally take a long time as your CPU has to mathematically re-verify all data from the start. This may take many hours.
  2. Rescan the block chain db.
    This will check the keys in your wallet against the blockchain (from block 0 by default) and update the wallet with any valid transactions found.

If you are importing a transparent unshielded address, I recommend you verify the funds are associated with the address on the zcash blockchain explorer first. If they are there, you can use another wallet like Coinomi to sweep the funds into another wallet.

If you are using a shielded z address, you can do one or more of the following (one at a time). If one option works, you do not need to perform additional steps.

a) Re-index your downloaded blockchain.
b) Re-import the private key (again) - this should start a rescan again.
c) Optionally - Start a Rescan Manually

For item a):

NOTE: The following commands assume a default installation using the Windows Installer Method (MSI Install File). If using the ZIP version, the path should be changed to the location of where the files were extracted.

  1. Close Zecwallet Fullnode.
  2. Run the following Command (Windows Key + R)
    %LOCALAPPDATA%\Programs\zecwallet\resources\bin\win\zcashd.exe -reindex

*You may open ZecWallet FullNode at this time to see any updates or changes.

It will take time to process the changes, but when done, I am not sure if closing ZecWallet Full Node will close zcashd.exe properly. To do this, run the following command:

%LOCALAPPDATA%\Programs\zecwallet\resources\bin\win\zcash-cli.exe stop

For item b) - Use the ZecWallet Full Node interface to import the key.

For item c), you have 2 options.
1st Option

  1. Edit the zcash.conf file and add rescan=1.

The zcash.conf file is a text file that can be opened in notepad. It is located at %APPDATA%\Zcash\zcash.conf.

  1. Save the file and restart ZecWallet.
  2. Remove the rescan option from the zcash.conf file or it will perform a full rescan on each start.

2nd Option
Perform the same steps as item a) above, but change the command to -rescan.
%LOCALAPPDATA%\Programs\zecwallet\resources\bin\win\zcashd.exe -rescan

I have shielded funds, and they are stuck in guarda shielded wallet. Guarda shielded wallet does not work at all. So i wanted to transfer my private keys to zec full node wallet. It seems it is not that plug and play. Thats because i like lite wallets.
Edit. If i want to export private keys, this last imported one is not there.

Imported key again, rescan again and finally worked.

3 Likes