ZecWallet balance is not syncronized

#1

I have downloaded and installed ZecWallet for both windows and mac os. I have got really bad user experience with the ZecWallet software. When i imported private key into the software, I got the alert box telling me that “the private key imported successfully”, but the balance is not synchronized. I have got two different balances in windows and mac os, which are not right balance either. Has someone meet the same problem?

#2

Is the blockchain fully synced for both your installations?

#3

Yes. It took quiet a while to sync fully. I know that, the problem happen after that. I check the balance with https://zcha.in/ as well.

#4

You may need to rescan to have your node reindex the Blockchain to find your funds if you imported the keys after it had already synced.

There is a way to start the Zcashd with the -rescan flag using the command line, but it depends how your system is configured.

For instance on Mac zcashd is in: zec-qt-wallet.app/Contents/MacOS/zcashd

Perhaps @adityapk00 or @garethtdavies would know an easier way to start with -reindex

Edit, try rescan before reindex per Gareths recommendation

1 Like
#5

Keep in mind that when you import the private key, the key is not imported instantly. It can take from several minutes to hours (depending on your hardware) for the process to finish due to blockchain rescanning in the background.

Are you still seeing the issue, now that 6 hours have passed?

3 Likes
#6

A rescan would actually be the best first step and will likely cure this and a reindex would be a last resort as it entails re-downloading the entire blockchain.

Assuming it has completed as @rex4539 points out and the balance is still not correct out I added some instructions for ZecWallet users here: https://docs.zecwallet.co/troubleshooting/#how-to-perform-a-wallet-rescan

Long story short though it’s just starting zcashd with a rescan option so zcashd -rescan.

As per that issue I think we could make this a lot easier with support in ZecWallet as this is a pretty common issue.

4 Likes
#7

I am trying rescan right now, and already took 10 minutes. How long does it usually take to rescan?

#8

@Shawn @garethtdavies @rex4539 zcashd -rescan worked. For people without computer background, the ZecWallet software still need to be refined. Correct balance should always show after importing private key without users doing anything.

3 Likes
#9

This makes absolutly sense. This is exactly one of the problems that hinder large adoption an usage. For devs and people familar to to wallets, crypto in general it’s an easy task. But for people new or with less knowledge with computing, software, wallets, whatever it’s something it’s a big burden.

Such things like an automatic rescan when importing private keys should be done just automaticaly to ensure people don’t run into problems that can be solved only with advanced computer/wallet knowledge.

#10

Just to be clear, this does happen by default https://zcash-rpc.github.io/z_importkey.html which is why importing a key typically takes a while. I’ve never tried to reproduce but I guess when you do the private key import relative to the sync progress matters. Maybe in addition to the ideas in that issue helping users perform a rescan, any importing of keys in ZecWallet is restricted until the node is fully synced (if that indeed is the issue).

1 Like
#12


I have tried importing again, and noticed the message as above. However, the User interface does not remind me the rescan is being processed. It does not show me the progress of the rescan either. Sometime people may not be patient to quit the Wallet, and I guess the rescan process would be terminated. When Wallet is relaunched, the rescan may not continue so that wrong balance is shown with the transactions partially rescanned. Please correct me if I got something wrong. but in general, the user experience of the Wallet really needs to be improved.

1 Like
#13

Yes, agreed but ultimately a lot of this is dependent on the functionality of the underlying zcashd so there are limits to what can be accomplished. Large wallet rescans for example can take a huge amount of time (days) but there is some research to improve it: https://github.com/zcash/zcash/issues/3889

Still there are some good suggestions and minor tweaks that can be made to improve things with ZecWallet. Copying @adityapk00 (ZecWallet dev) to make sure he sees this thread but also opening an issue here: https://github.com/ZcashFoundation/zec-qt-wallet/issues to suggest stuff would also be very welcome!

3 Likes
#14

Issue submitted in github already.

1 Like