Zcash miner only sees 1 card

Hi im new to this site but would really appreciate some guidance. I build a 4 x rx470 rig, with buistar tb85 mobo. Installed latest driver on win10. Problem is windows sees all the cards but the claymore miner software only sees 1 card. Any ideas?

An Idea and a solution- since you stated you are running the lastest driver that is the problem.

Run the AMD DDU in safe mode

Then per Claymore's recommendations: For 4xx cards (Polaris) Crimson 16.12.2 is recommended.

Still not working, tried DDU and installed 16.12.2 - no luck
I tried another new tb85, same problem.
I got as far as windows seeing all my cards but claymore miner v12 only sees 1 card.
Is there a specific way to setup 6 x cards on the TB85 boards cause im really struggling

Appreciate the help.

Do you have it stated in your .bat file? i don't use claymore but in my .bat you have to use a device command - cuda_devices 0 1 2 3 4. Some miners if you leave it blank will use all the cards, i have another .bat file so i can use one of my gpu's for gaming which is just - cuda_devices 1

Unfortunately not - i have a second setup with just a maximus hero 7 board, using the same .bat file. that is working perfect.

If you know a card and a riser works,remove it and try a different card solo.. if it works try the same card in a different slot, does it work? yes? then add the card you know works into the riser you know works. If it does works/ If it see's both cards and runs, after 5 minutes try a third, and rinse and repeat. could be a resource issue

are you using single cable risers or two risers per cable?
two CABLES are bad..

Do you have enough power to run all 6 and the system?