Zcash's current performance issues are frustrating

Thx… it says it is?
Zcash Full Node and CLI — Zcash Documentation 5.2.0 documentation

Docker?? any suggestions are appreciated all.

Well - it says Windows (unsupported) but Other Linux Systems (best effort supported)…

For docker, it’s fairly straightforward but you need to be a bit familiar with it. I suggest you follow the link and grab a tutorial on Docker.

No it’s not officially supported but you should be able to run zcashd.exe on a terminal in the dir it resides in as well as zcash-cli.exe “option”. With the reindex flag you shouldn’t have to wait for completion to run the rpc

I am trying anything & everything… thanks for the suggestion but tries but errors
Messages:

  • Error: Unable to start HTTP server. See debug log for details.

**There is no debug log. It doesn’t create one in the roaming folder like it states

The Ubuntu node is reindexing again because it on load now starts says scanning than just stops. No message just a flashing prompt.
Thx again

Apache issue?

Can you verify your Ubuntu 4win version from the microsoft app store? There is definitely more than just the latest '22 but apparently '18 had issues like this. AND I have recently incurred similar issues in WSL2 on UB22 for win10 with zecwallet lite cli. They seem connection related too (but different than yours). You might need to run as admin to allow firewall access perhaps?

Just use another machine or docker. If you want your coins, no need to fafo.

1 Like

What do you mean?? NONE OF THIS WORKS & ZEC community has been given coins from every block to support the community. WHERE ARE THEY?? There are many wanting their coins & everyone is being ignored.

The freaking node wont even load any longer. It is doing nothing but reindexing over & over & over.

Zcash you are creating enemies with press contacts & political power

You do not want someone who has lost $10k coming after all of you. You will not like the attention you will get I PROMISE

Spend some $$$ on a grant & fix this junk

TY I do appreciate any ones help.
my Ubuntu should be fully updated & current version. BUT, I did install wsl & updated/upgraded that to try other possible solutions & “NOW” when I run zcashd it launches, scans & stops no errors.
Then I did a reindex & it does it as “drive space ex: 141GiB”
Reindexing blocks | 59.51 GiB / 142.76 GiB (41%, 0 blocks)
Next upgrade | Overwinter at block height 347500, in around 603 days
Connections | 8
Network solution rate | 0.000 Sol/s

And when it finishes it will just stop there?
So I think you are correct… wsl version 2 is probably causing another behavior…

When its done indexing again, I will try the run as admin just to see.

**AT THE END OF THE DAY FOR ZCash THE PUBLIC WILL NOT DO THIS
The public will not tolerate having you being rewarded coins from every block while doing nothing for the community & theirs.

Get to work ZCash

1 Like

Have you actually tried Docker? I’m pretty sure that fiddling with WSL2, Ubuntu versions, zcashd, etc. is not the easiest path toward getting your coins. IMO, you’re making it harder than necessary.

This is my fullnode:

So I’m sure you have adequate hardware. The software part is probably messed up.

1 Like

If it succeeds in reindexing then it should just continue on as normal and you shouldnt need to reimdex yet again

I have not but I will take a closer look after stepping away from this for a bit.

Time for a break… TY again

Its almost done… here’s what it says at the moment.
Notice it says 0 blocks & 0 network rate & it stopped counting up transactions long ago
Has not moved past 1498858 in quite a while
When it finishes I’ll post it but it will go straight back to a prompt
Will try run as admin
TY again
Reindexing blocks | 136.63 GiB / 142.76 GiB (95%, 0 blocks)
Next upgrade | Overwinter at block height 347500, in around 603 days
Connections | 8
Network solution rate | 0.000 Sol/s
Since starting this node 4 hours, 9 minutes, 33 seconds ago:

  • You have validated 1498858 transactions!
    [Press Ctrl+C to exit] [Set ‘showmetrics=0’ to hide]

You will have more luck looking at the ‘debug.log’ file, that has much more detail of what the node is doing.

You could try rebuilding zcashd off the newest master as mentioned in the other thread in WSL2 and then import the 2 problem keys individually

Zecwallet.Fullnode-1.7.8-win after i sync was unable to start error said this wallet block after so and so block number was forced to use Zecwallet.Fullnode-1.8.3-win which told me i need to start a new wallet

I again return to Zecwallet.Fullnode-1.7.8-win it worked I got access to my coins. Obviously I don’t trust this Fullnode anymore I immediately relocated them. The blockchain is growing a GIG a month for whatever reason. That doesn’t seem sustainable to me can’t imagine syncing a terabyte from scratch It won’t happen I still like the Zcash coin but the developers need to assure NOBODY EVER GOES TO A WALLET AND SEE ZERO BECAUSE A UPDATE DIDN’T WORK Or if they know its going to happen a well EXPLAINED WORK AROUND IS REQUIRED. It not like the guy with a wallet has any control of the software hes at the developers mercy

1 Like

Who are you upset at? The devs of zecwallet, the ECC, the ZF, the community, etc. ?

2 Likes

I blame Windows

1 Like

Synced ywallet on airport WiFi, just because I could. :wink:

4 Likes

NUMBER ONE the developers originally put a block on wallet Zecwallet.Fullnode-1.7.8-win

THEY ONLY REMOVED THE BLOCK BECAUSE I B!TCHED

THE WALLET DAT FROM 1.7.8 STILL DOESN’T WORK ON 1.8.3

The IDEA I WOULD have to transfer my coins out of Zecwallet.Fullnode-1.7.8-win and Back TO 1.8.3 to continue using the FULL NODE IS BULLSH!T

1 Like