CUDA SILENTARMY v4+ Windows Build

I finished a build of a CUDA version of silent army. It is located here: https://github.com/maztheman/nheqminer/releases/tag/v0.4e

let me know what you think.

-maztheman

2 Likes

Anyone tested this?
I tried to run this .exe file and nothing happened.

Just ran this. So weird. Verified speed with pool.

Well I just copied those files to NiceHash folder and I'm getting lower speed than before.
GTX 1070 only doing 30sol/s
With stock NiceHash settings it's getting at least 34

Could you please reenable the colored output..with CONSOLE_COLORS in PREPROCESSOR Directive?

And the cuda solver has an issue:
[21:37:34][0x00002dac] Speed [300 sec]: 36.2226 I/s, 68.4205 Sols/s
cuda solved 6
cuda solved 1
cuda solved 0
cuda solved 3
cuda solved 2
cuda solved 2
cuda solved 4
cuda solved 2

thats the output running on the screen like there is no hell

Which GPU is giving you 68 sols/s ?

You have to add -cs to the command line to use the new cuda silent army

Also I updated it again based off the latest innovation over at silentarmy!!
get it here: https://github.com/maztheman/nheqminer/releases/tag/v0.4f

-maztheman

io: ug i thought i removed that code...try -cs to use new cuda silent army

-t 0 -cs -cd 0

what command line did you use?

Okay i give it a shot.

also remember that -cb and -ct can change the block size and threads per block..i had to monkey around with my gtx 650 before i got "okay" results.

Oh banana, This will not work out of the box with nicehash, I would have to default to using the silentarmy cuda in order for that to happen....

let me know what you think its the most sane defaults...

Well nothing happenes with SA Cuda..just loads and high the clock but :;
[21:53:06][0x00001464] stratum | Received new job #c8e
[21:53:06][0x00001464] stratum | Authorized worker ioglnx.GTX1080
[21:53:17][0x00002e30] Speed [300 sec]: 0 I/s, 0 Sols/s
[21:53:27][0x00002e30] Speed [300 sec]: 0 I/s, 0 Sols/s
[21:53:38][0x00002e30] Speed [300 sec]: 0 I/s, 0 Sols/s
[21:53:49][0x00002e30] Speed [300 sec]: 0 I/s, 0 Sols/s
[21:53:59][0x00002e30] Speed [300 sec]: 0 I/s, 0 Sols/s
[21:54:05][0x00001464] stratum | Received new job #c8f
[21:54:05][0x00001464] stratum | Received new job #c8f
[21:54:10][0x00002e30] Speed [300 sec]: 6.32215 I/s, 0.566162 Sols/s
[21:54:26][0x00002e30] Speed [300 sec]: 27.366 I/s, 2.89184 Sols/s
[21:54:27][0x0000060c] stratum | Submitting share #4, nonce 000000000000000000000000010001b6
[21:54:27][0x00001464] stratum | Accepted share #4
[21:54:37][0x00002e30] Speed [300 sec]: 38.4149 I/s, 4.04426 Sols/s

I have:
21:53:06][0x00001464] stratum | Starting miner
[21:53:06][0x000010b8] miner#0 | Starting thread #0 (CUDA-SILENTARMY) GeForce GTX 1080 (#0) BLOCKS=640, THREADS=64
[21:53:06][0x0000060c] miner#1 | Starting thread #1 (CUDA-SILENTARMY) GeForce GTX 1070 (#1) BLOCKS=480, THREADS=64
[21:53:06][0x000036d4] miner#2 | Starting thread #2 (CUDA-SILENTARMY) GeForce GTX 1080 (#2) BLOCKS=640, THREADS=64
[21:53:06][0x00003440] miner#3 | Starting thread #3 (CUDA-SILENTARMY) GeForce GTX 1070 (#3) BLOCKS=480, THREADS=64
[21:53:06][0x00001464] stratum | Connecting to stratum server zec.suprnova.cc:2142
[21:53:06][0x00001df8] miner#4 | Starting thread #4 (CUDA-SILENTARMY) GeForce GTX 1080 (#4) BLOCKS=640, THREADS=64

try reducing the blocks like -cb 60 or threads like -ct 256

and what blocksize and threads are you using? i have the same gpu.

GTX 650, -ct 64 -cb 64

i might have to turn down the thread block size instead of SM_COUNT * 32 to maybe SM_COUNT * 10 ?

I usually have no problems with 64 threads also the blocksize is what i also normally have. when using tromp solver.
All gpus have 99% load and 22% mem controller load. but crippling at 7sol/s

Something strange i noticed.
Speed [300 sec]: 112.812 I/s, 10.6195 Sols/s shouldn't it be around 200..

my compiled verison from nheq 03b looks your calculations are wrong :smiley:

[2016-11-10 16:27:40.710659][0x00002e10]: stratum | Accepted share #1378
[2016-11-10 16:27:50.430199][0x00002548]: Speed [300 sec]: 52.6567 I/s, 99.7233 Sols/s
[2016-11-10 16:28:00.937329][0x00002548]: Speed [300 sec]: 52.62 I/s, 99.6267 Sols/s
[2016-11-10 16:28:04.954408][0x00002c88]: stratum | Submitting share #1379, nonce 08000000000000000000000000000000000000000000000000000b29
[2016-11-10 16:28:04.994408][0x00002e10]: stratum | Accepted share #1379
[2016-11-10 16:28:06.402450][0x00002704]: stratum | Submitting share #1380, nonce 06000000000000000000000000000000000000000000000000000b3d
[2016-11-10 16:28:06.437949][0x00002e10]: stratum | Accepted share #1380
[2016-11-10 16:28:11.249497][0x00002e10]: stratum | Received new job #9fc
[2016-11-10 16:28:11.436503][0x00002548]: Speed [300 sec]: 52.5833 I/s, 99.4 Sols/s

nheqminer.exe -l stratum.zcash.nicehash.com:3357 -u t1ZQLKLXDc4mYBAuBwbKy5B4PjaVYmmSiME -t 0 -cd 0 -cb 60 -ct 128

This gives me around 30 sol/s with GTX 1070.

1 Like

What does this do:

nheqminer.exe -l stratum.zcash.nicehash.com:3357 -u t1ZQLKLXDc4mYBAuBwbKy5B4PjaVYmmSiME -t 0 -cs cb 60 -ct 128 -cd 0

I didnt do any work on cuda_tromp. and Also you can try:

nheqminer.exe -l stratum.zcash.nicehash.com:3357 -u t1ZQLKLXDc4mYBAuBwbKy5B4PjaVYmmSiME -t 0 -od 0

1 Like

Here also other miner [19:29:19][0x00002fb4] stratum | Submitting share #172
[19:29:19][0x00002674] stratum | Accepted share #172
[19:29:19][0x00003630] speed | 198.717 I/s, 341.583 Sols/s [300 sec]

Your calculations are wrong of sol/s ..