CUDA SILENTARMY v4+ Windows Build

nheqminer.exe -l stratum.zcash.nicehash.com:3357 -u t1ZQLKLXDc4mYBAuBwbKy5B4PjaVYmmSiME -t 0 -cs cb 60 -ct 128 -cd 0

Does this:

Setting log level to 2
[22:04:01][0x000039c0] Using SSE2: YES
[22:04:01][0x000039c0] Using AVX: YES
[22:04:01][0x000039c0] Using AVX2: YES
[22:04:01][0x000039dc] stratum | Starting miner
[22:04:02][0x000039dc] stratum | Connecting to stratum server stratum.zcash.nicehash.com:3357
[22:04:02][0x000039e0] miner#0 | Starting thread #0 (CUDA-SILENTARMY) GeForce GTX 1070 (#0) BLOCKS=60, THREADS=128
[22:04:02][0x000039dc] stratum | Connected!
[22:04:02][0x000039dc] stratum | Subscribed to stratum server
[22:04:02][0x000039dc] miner | Extranonce is 47fea33e000000000000000047fea33d
[22:04:02][0x000039dc] stratum | Target set to 03c3c3c000000000000000000000000000000000000000000000000000000000
[22:04:02][0x000039dc] stratum | Received new job #32c
[22:04:02][0x000039dc] stratum | Authorized worker t1ZQLKLXDc4mYBAuBwbKy5B4PjaVYmmSiME
[22:04:17][0x000039c0] Speed [300 sec]: 98.3293 I/s, 0 Sols/s
[22:04:28][0x000039c0] Speed [300 sec]: 96.4224 I/s, 0 Sols/s
[22:04:43][0x000039c0] Speed [300 sec]: 92.9662 I/s, 0 Sols/s
[22:04:49][0x000039dc] stratum | Ignoring non-clean job #32d
[22:04:58][0x000039c0] Speed [300 sec]: 89.3633 I/s, 0 Sols/s
[22:05:04][0x000039dc] stratum | Received new job #32e

I Have met my reply limit for today.
Any other issues you want me to look at you can use this site:

ug... try -ct 64 ?

maybe its some wierd, shitty bug on the cuda code :frowning: well thanks for testing this for me...

When ever i tried >64 on my GTX 650 it never worked, 0 Sols just like you. Maybe its because im including such old generation compute units

Here numbers are very screwed up...
X:\Mining\nheqminer_v0.4e>nheqminer.exe -l zec.suprnova.cc:2142 -cs -cd 0 -ct 32 -t 0

    ==================== www.nicehash.com ====================
            Equihash CPU&GPU Miner for NiceHash v0.4b maztheman
    Thanks to Zcash developers for providing base of the code.
           Special thanks to tromp, xenoncat, mbevand
                 and eXtremal-ik7 for providing
          optimized CPU, CUDA and AMD equihash solvers.
    ==================== www.nicehash.com ====================

Setting log level to 2
[22:07:10][0x00002d1c] Using SSE2: YES
[22:07:10][0x00002d1c] Using AVX: YES
[22:07:10][0x00002d1c] Using AVX2: YES
[22:07:11][0x00002dfc] stratum | Starting miner
[22:07:11][0x00002dfc] stratum | Connecting to stratum server zec.suprnova.cc:2142
[22:07:11][0x00002ee0] miner#0 | Starting thread #0 (CUDA-SILENTARMY) GeForce GTX 1080 (#0) BLOCKS=640, THREADS=32
[22:07:11][0x00002dfc] stratum | Connected!
[22:07:11][0x00002dfc] stratum | Subscribed to stratum server
[22:07:11][0x00002dfc] miner | Extranonce is 80b3ff37000000000000000037ffb37f
[22:07:11][0x00002dfc] stratum | Target set to 00f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0
[22:07:11][0x00002dfc] stratum | Received new job #276
[22:07:11][0x00002dfc] stratum |
[22:07:21][0x00002d1c] Speed [300 sec]: 6.29531 I/s, 2.19382 Sols/s
[22:07:32][0x00002d1c] Speed [300 sec]: 13.972 I/s, 3.73224 Sols/s
[22:07:42][0x00002d1c] Speed [300 sec]: 16.5506 I/s, 4.37728 Sols/s
[22:07:53][0x00002d1c] Speed [300 sec]: 17.8332 I/s, 4.62608 Sols/s
[22:07:56][0x00002dfc] stratum | Received new job #277
^C
X:\Mining\nheqminer_v0.4e>nheqminer.exe -l zec.suprnova.cc:2142 -cs -cd 0 -ct 32 -cb 128 -t 0

    ==================== www.nicehash.com ====================
            Equihash CPU&GPU Miner for NiceHash v0.4b maztheman
    Thanks to Zcash developers for providing base of the code.
           Special thanks to tromp, xenoncat, mbevand
                 and eXtremal-ik7 for providing
          optimized CPU, CUDA and AMD equihash solvers.
    ==================== www.nicehash.com ====================

Setting log level to 2
[22:08:07][0x00003648] Using SSE2: YES
[22:08:07][0x00003648] Using AVX: YES
[22:08:07][0x00003648] Using AVX2: YES
[22:08:08][0x00003514] stratum | Starting miner
[22:08:08][0x00003514] stratum | Connecting to stratum server zec.suprnova.cc:2142
[22:08:08][0x00001f5c] miner#0 | Starting thread #0 (CUDA-SILENTARMY) GeForce GTX 1080 (#0) BLOCKS=128, THREADS=32
[22:08:08][0x00003514] stratum | Connected!
[22:08:08][0x00003514] stratum | Subscribed to stratum server
[22:08:08][0x00003514] miner | Extranonce is 98360020000000000000000020003699
[22:08:08][0x00003514] stratum | Target set to 00f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0
[22:08:08][0x00003514] stratum | Received new job #159
[22:08:08][0x00003514] stratum |
[22:08:18][0x00003648] Speed [300 sec]: 5.73011 I/s, 10.0277 Sols/s
[22:08:28][0x00001f5c] stratum | Submitting share #4, nonce 000000000000000000000000000000f6
[22:08:28][0x00003514] stratum | Accepted share #4
[22:08:29][0x00003648] Speed [300 sec]: 12.7001 I/s, 23.9624 Sols/s
[22:08:30][0x00001f5c] stratum | Submitting share #5, nonce 00000000000000000000000000000119
[22:08:30][0x00003514] stratum | Accepted share #5
[22:08:33][0x00001f5c] stratum | Submitting share #6, nonce 00000000000000000000000000000154
[22:08:33][0x00003514] stratum | Accepted share #6
[22:08:33][0x00001f5c] stratum | Submitting share #7, nonce 0000000000000000000000000000015b
[22:08:33][0x00003514] stratum | Accepted share #7

With -ct 64 I get around 34 sol/s.
So same as NiceHash miner does.
I was hoping for 50 sol/s with this GPU :frowning:

nheqminer.exe -l stratum.zcash.nicehash.com:3357 -u t1ZQLKLXDc4mYBAuBwbKy5B4PjaVYmmSiME.banana -t 0 -cs -cb 256 -ct 32 -cd 0

This gives me 43 sols/s on GTX 1070.
Finally some increase from 34 sol/s xD

1 Like

I initially used the launch default. Got it running well now with -cb 64.

GTX 1080 im only getting 29-30 Sols :frowning:

hi.
my GTX1060 3Gb launch with -cd 0 -cs work only on CUDA TROMP 75 (OS win 7 x64)
or
GTX1060 3Gb launch with -od 0 work on OCL SILENTARMY, and getting 30 sol

stupid options :slight_smile:
you have to set -t 0 -od 0 only to run silentarmy on nvidia, i got 43 s/s as mentioned above
-cs option doesn't work
anyway it's too slow compared to devfee zcminer (58 s/s)

GTX750Ti + 2*GTX750 + i5 3340 -cd 0 1 2 -t 4 -cb 64 64 64 -ct 64 64 64 -cs
i got 60 sol
work on CUDA SILENTARMY (OS Win 7 x64)

-cs option does work, on gtx980 without cs i get 25 sols on cuda_tromp, with cs and right cb,ct i get 38 sol/s on cuda_silentarmy, with zcminer i got 40 max (and often lower like 32) so with dev fee is the same speed or lower and use cpu core... But whole nheqminer compiled by self and spend time to find good cb,ct for my card... I could try compile cuda_silentarmy.dll for comparision if someone wants. Still eth more profitable.

what .exe to use? i tried all of your builds, -cs option does nothing, the console writes cuda_tromp
and only -od 0 gives me ocl_silentarmy
an example of my cmd:
nheqminer.exe -l *** -u *** -cd 0 -t 0 -cs -cb 256 -ct 32
it uses cuda_tromp, why?

Are you using right files? For reminder https://github.com/maztheman/nheqminer/releases

I try all files. and -cs option don`t work on AMD motherboard with GTX1060 + GTX650Ti

c:\coin\zcash\nheqminer_v0.4f>nheqminer.exe -l equihash.eu.nicehash.com:3357 -u *** -cd 0 -t 0 -cb 256 -ct 32 -cv 0 -cs

    ==================== www.nicehash.com ====================
            Equihash CPU&GPU Miner for NiceHash v0.4b maztheman
    Thanks to Zcash developers for providing base of the code.
           Special thanks to tromp, xenoncat, mbevand
                 and eXtremal-ik7 for providing
          optimized CPU, CUDA and AMD equihash solvers.
    ==================== www.nicehash.com ====================

Setting log level to 2
[15:44:58][0x00000cd4] Using SSE2: YES
[15:44:58][0x00000cd4] Using AVX: NO
[15:44:58][0x00000cd4] Using AVX2: NO
[15:44:59][0x000020b8] stratum | Starting miner
[15:44:59][0x000020b8] stratum | Connecting to stratum server equihash.eu.nicehash.com:3357
[15:44:59][0x000006cc] miner#0 | Starting thread #0 (CUDA-TROMP) GeForce GTX 1070 (#0) BLOCKS=256, THREADS=32
[15:44:59][0x000020b8] stratum | Connected!
[15:45:00][0x000020b8] stratum | Subscribed to stratum server

with any of your .exe
v0.4f.7z
v0.4f_Color.7z
v0.4f_SM50_62.7z

Yes maztheman will have to look at that, i suspect lack of avx and it falling with old code or some other bug

The problem is as far as I can se from compiling and debugs that nheqminer introduced a strange behaviour with loading the nvidia gpus..it takes awhile until the GPU actually starts to work and process the hash.

It takes than a long time until you reach the final hashrate..i let it run 8h and just reached 100h with nheqminer 0.3b it was in seconds at 200h - 250h..something is wrong since they implemented the 7.5 solver

with option -cv 0
GTX1060 now work!!!
PS
Work but only 20 sol (change -cb -ct without result):frowning:

OCL SILENTARMY 30sol

yeah, the problem is with avx, i tested it on old core2quad q9300
i've just run it on another rig with g1840, it's showing cuda-silentarmy