Help regaining access to funds from Zepio

Hello,

I installed Zepio a little over a month ago. It worked great, synced (took a few days), and I moved a non-trivial amount of funds into a z-address in the Zepio wallet. I did save an offline backup of the wallet.dat file. Everything was working great.

Then I didn’t use Zepio again for a little over a month. When I fired it back up, I started getting " Zepio could not find a daemon running" errors.

Note: I’m using version 0.9.0 on Mac OS.

I tried the following things and none of them solved the problem:

  1. Restarting Zepio.
  2. Uninstalling an reinstalling Zepio and letting it sync again (took days).
  3. Installing ZecWallet Full Node (got a similar error: “Failed to start zcashd. Giving up!
    Please file an issue with Zecwallet”)

Sometimes I can see zcashd running in the background, using ~100% CPU (according to Activity Monitor).

I see there is an open issue about this on GitHub (https://github.com/ZcashFoundation/zepio/issues/167) but it has been open for a half a year, so I don’t think it will be addressed there.

If anyone can help me get access to my funds I would greatly appreciate it. The amount of money I had in Zepio is enough that I’m willing to buy a non-mac laptop to get access to my funds if that is what’s needed here.

Thanks in advance.

You are most likely running into this issue: https://github.com/zcash/zcash/issues/4301

You will need to run zcashd with a reindex.

Please look at this issue and this comment for instructions: https://github.com/ZcashFoundation/zecwallet/issues/247#issuecomment-597362127

1 Like

Just to be sure, could you post your debug.log?

It’s located in ~/Library/Application Support/Zcash

1 Like

@adityapk00 Could you ping me on Discord? I have an idea how to fix this once and for all.

2 Likes

I’m in the middle of a long series of virtual meetings for work. But I’ll ping you when I have a moment.

Please look at this issue and this comment for instructions

Those instructions are for a Windows machine. I’m on Mac OS.

But in my best attempts initiate a reindex, I deleted the Zcash/chainstate/ folder and restarted Zepio.
That did something (required several hours) that used 99% of CPU and ~0 network activity. I assume/hope that was a reindex.

It’s located in ~/Library/Application Support/Zcash

Found it. This is the part that I suspect you’re looking for:

2020-03-19 01:39:23 *** This version has been deprecated as of block height 734240. You should upgrade to the latest version of Zcash.
2020-03-19 01:39:26 Verifying last 288 blocks at level 3
2020-03-19 01:39:26 Shutdown requested. Exiting.
2020-03-19 01:39:26 Shutdown: In progress...
2020-03-19 01:39:26 scheduler thread interrupt
2020-03-19 01:39:26 StopRPC: waiting for async rpc workers to stop
2020-03-19 01:39:26 StopNode()
2020-03-19 01:39:26 Shutdown: done

UPDATE: Here’s my guess. My guess is that when I first install Zepio it installs the latest version of zcashd. Then (for some reason) that version of zcashd expires over time (not sure if that’s a feature of zcashd or Zepio), so it can no longer be used by Zepio.

When I reinstalled Zepio it noticed that zcashd was already installed, and so didn’t install the latest version. And that’s maybe why the error persisted even after a reinstall of Zepio.

So to test that hypothesis, I just deleted everything related to Zcash and Zepio from my computer. Hopefully that got rid of the existing zcashd. Now I’ll reinstall Zepio and cross my fingers. Hopefully this results in a newer version of zcashd being installed and then I’ll be able to (somehow) import my wallet.dat file that I backed up. :crossed_fingers:

I will update here if that works (and after it syncs again, which may be a few days).

Each version of zcashd expires around 16 weeks after it is released. Here is the relevant code:

1 Like

Thank you! I will keep this in mind.

Does anyone know how to upgrade a version of zcashd on Mac OS (without having to delete everything and reinstall + resync)? That would make it easier on me since I intend to hold my coins in a zaddress for more than 16 weeks.

Do not run Zepio again. This software is deprecated and will not work.

Run the latest Zecwallet and pray you will not hit https://github.com/zcash/zcash/issues/4301 again.

1 Like

@adityapk00 I have a suggestion to help poor folks with this bug. Compile zcashd from latest master and make a “beta” release of Zecwallet so you can point everyone who hits this bug to that build. Don’t make a proper release on GitHub, just host it on https://www.zecwallet.co under some special link.

2 Likes

You’re probably right. I might have to do this. I was hesitant at first of doing a release with a master zcashd, but I think too many people are hitting this.

1 Like

I’m afraid Zepio is the only chance I’ve got right now. :frowning:

I installed the latest ZecWallet, but when I start it I get the error “Failed to start zcashd. Giving up!!!” (though I can see zcashd is running in the background).

Zepio is currently “syncing”. I’m just hoping that when it finishes I’ll have access to my coins. :pray:

Running zcashd as daemon ( with the daemon=1 flag in the .conf) can cause issues, if its there you might try deleting that line from the script and restart the wallet

2 Likes

My zcash.conf file has only one line in it: server=1.

UPDATE: After reinstalling Zepio (which reinstalled zcashd) and letting it sync, I ran into the same issue/error again. :frowning:

I’m not sure what else to try at this point. Neither Zepio nor ZecWallet are working for me.

Are either of these wallets working for anyone else on Mac OS?

Are either of these wallets working for anyone on Linux? I’m willing to buy a laptop, install Linux, and try to install Zepio or ZecWallet on that computer – but I’d like to hear that there exist Linux users for whom either of these wallets work before I spend the money to do that.

Another question: are there any lite wallets that I can import my wallet.dat file into, and then use to move coins out of my Zaddress? I know using a lite client will kill my privacy, but at this point I just want to get access to my coins any way I can.

EDIT/UPDATE: I’m going to buy a used laptop and install linux on it today. I will update here when it’s set up.

@Austin-Williams - You need to run zcashd with a reindex to make it work.

Please do the following:

  1. Download and install Zecwallet for Mac
  2. Open a Terminal window
  3. cd /Applications/Zecwallet Fullnode.app/Contents/Resources/bin/mac
  4. Run ./zcashd -reindex

This should hopefully start zcashd and do a full reindex. After it finishes, you can double click and start Zecwallet

1 Like

Also, for everyone: I’d recommend you use the Lite wallet, unless you are technical enough to run the command line zcashd. The Lite wallet will let you import and export your seed, doesn’t require a sync, and I can actually provide support and fix bugs with the Lite client.

Thanks!

3 Likes

Please do the following:

I was unable to get past step 3. There is no /Contents/ directory, and I’m getting command not found: zcashd errors.

I think for next steps I’ll try to use the Lite wallet.