Mining rig freeze problem

hi everyone. i have started mining zcash a few weeks ago. i have a miner with windows 10, asrock h110 mainboard, celeron cpu, 4gb ram, 120gb ssd, a 1600w psu and 4 colorful geforce 1060 3gb vgas. i’m planning on adding 8 gpus later, but at the moment my rig freezes frequently and i need to find a solution for it. i’m using ewbf cuda miner which gives me around 1200 sol/s. i tried funakoshi, but it doesn’t work and gives me “stream truncated” error. don’t know what it means. also tried nehq which was horrible and gave me 100 sol/s on all gpus!! cuda works fine for a few hours but freezes after a while. i even set the max temp at 70, but it still freezes. any idea what to do? could it be software related? i removed my anti virus and only have windows defender.
any help is appreciated.

Hi,

  • Have OC your GPU´s how much or at all ?
  • How much you have virtual memory allocated ?
  • When your rig works, does any GPU run notably hotter than others or do they all stay same ten of degree?
  • How long you can mine about before it freezes (15 min or 24 hours)?

For mining programs there are:

DSTM (ZM miner) Pretty fast and stable, but 2% devfee
B Miner fast as well, but what I have read about it sounds little strange, 2% devfee
Nicehash Excavator 1.4.4 and lower, no fees, needs little config, pretty stable but not the fast as others (I personally use it, after find right OCs (1080ti gives me ~750 sol/s)).

Mining with 1060 topic in here, not so much of problems but performance and OC and profit.

1 Like
  1. not at all. i’m still learning and want to see stable results first.
  2. didn’t change it in windows. should i?
  3. no. they’re usually all stay close in temp to each other.
  4. sometimes it works more than 10 hours before freezing, but last night and today it worked 1-2 hours only and then froze.

started trying another version of nehq. so far it’s working fine.but it’s slower (800-1000 sol/s for 4 gpus). if i try nicehash excavator do i need lots of configurations? i’m new to this as you can see. thanks.

I am pretty new to this as well but I am thinking open your task force while you are mining. See what kind of load is on your machine. You may need higher ram in your rig. I think I was told Windows 10 likes around 8gb. Anything less and I think you will get bottlenecks and freeze ups.

2 Likes
  1. Ok, smart move :+1:
  2. I cant promise that it will solve all those freezing problems but for 4 cards I would use 64GB and more GPU´s more virtual memory. I have 64GB for 3 GPU´s virtual memory.
  3. Sounds like all GPU´s are fine if they stay in close each others.
  4. :slightly_frowning_face:

I might freeze because amount of RAM, Check this asrock forum topic
Like popojo07 allready did say.

And here are good topic too.

Do you know how well JSON? You configure excavator with that.
I Can send you working example config (without OC you can add OC later) if you want to, but I need some info from your

  • Pool
  • GPU´s I know ( 4 x 1060)
  • Wallet t address and desired workername

[EDIT] Check that you have lastest bios.

1 Like

Does your whole rig freeze and you need to restart it? Or is it just the miner? You could try the watchdog script and see if that keeps your rig running. The script won’t fix the underlying problem, of course, but if it restarts the miner just 3-4 times each day, the few seconds you “lose” mining during the miner restart won’t add up to any significant time.

Link to watchdog thread: [CMD] FarmWatchBot (Autorun/Watchdog) for Ewbf, Claymore, Dstm, CCminer, Bminer, Ethminer, CastXMR, Phoenix

2 Likes

If you dont have enough space for 64 gig of virtual memory (although I’m assuming you do because you have a 120 gb ssd) 16 or 32 gigs should be fine. I use 16 Gigs of virtual memory for my 5 card rigs.

1 Like

thanks alot for your help man! i’ll try all the solutions you mentioned. will add 4gb of ram and increase my virtual memory, and see what happens. as for my mining info, i’ll pm you.

the whole rig freezes and i need to turn off psu so i can start mining again.

If you dont have 4 gigs on hand maybe try adding Virtual memory before hand so you dont need to buy more if that fixes it.

1 Like

thanks. will try that first. i suppose with 120gb ssd and no other uses on the rig, it’s safe to increase it to 64gb, right?

  1. what mining software are you using? You mention funakoshi (which imo is crap right now) and NEHQ which is long outdated. You should use either EWBF or DSTM to mine with Nvidia cards

  2. to increase your VM
    For multi-GPU systems, set Virtual Memory size in Windows at least 16 GB:
    “Computer Properties / Advanced System Settings / Performance / Advanced / Virtual Memory”.

  3. are you over clocking or underclocking or running stock?

  4. risers - are they sata / molex / or pin powered?

1 Like

Here are config for you and everybody else who needs it for Excavator mining.
It is not the fastest miner for ZCASH but it cointains 0% devfee and pretty stabile after right OC.
I am using it for my left over GPUs (1080ti, 1080, 1050) and get ~1500 sols/s.

You can copy paste this in new text document and rename it wanted_file_name.json

  1. Download Excavator and extract.

  2. Copy / make wanted_file_name.JSON file in that extrated folder.

  3. Create start.bat in extracted excavator folder.For start.bat copy these lines.

    :restart
    @echo off
    excavator -c "wanted_file_name.json" -d 2 -f 6 -p 0 -wp 38081 -wi 127.0.0.1 -ca
    ping 127.0.0.1 > nul
    goto :restart

Here are that excavator example config .json file.

[
	    {"time":1,"commands":[
		{"id":1,"method":"algorithm.add","params":["equihash","POOL HERE:PORT HERE","WALLET.WORKERNAME:PASSWORD"]}
	]},
	{"time":2,"commands":[
		{"id":1,"method":"worker.add","params":["0","0"]}, # Here you add worker for first GPU (GPU0)
		{"id":1,"method":"worker.add","params":["0","1"]}, # Here you add worker for second GPU (GPU1)
		{"id":1,"method":"worker.add","params":["0","2"]}, # Here you add worker for third GPU (GPU2)
		{"id":1,"method":"worker.add","params":["0","3"]}, # Here you add worker for fourth GPU (GPU3)
		{"id":1,"method":"device.set.tdp","params":["0","100"]}, # Here you set GPU0 TDP Value 100% is default
		{"id":1,"method":"device.set.tdp","params":["1","100"]}, # Here you set GPU1 TDP Value 100% is default
		{"id":1,"method":"device.set.tdp","params":["2","100"]}, # Here you set GPU2 TDP Value 100% is default
		{"id":1,"method":"device.set.tdp","params":["3","100"]}, # Here you set GPU3 TDP Value 100% is default
		{"id":1,"method":"device.set.fan.speed","params":["0","50"]}, # Here you can set fan speed GPU 0, change that 50 to your wanted number value is 0-100%
		{"id":1,"method":"device.set.fan.speed","params":["1","50"]}, # Here you can set fan speed GPU 1, change that 50 to your wanted number value is 0-100%
		{"id":1,"method":"device.set.fan.speed","params":["2","50"]}, # Here you can set fan speed GPU 2, change that 50 to your wanted number value is 0-100%
		{"id":1,"method":"device.set.fan.speed","params":["3","50"]}, # Here you can set fan speed GPU x, change that 50 to your wanted number value is 0-100%
		{"id":1,"method":"device.set.core_delta","params":["0","0"]}, # Here you can set Core Clock speed for GPU0, 0 is default clock
		{"id":1,"method":"device.set.core_delta","params":["1","0"]}, # Here you can set Core Clock speed for GPU1, 0 is default clock
		{"id":1,"method":"device.set.core_delta","params":["2","0"]}, # Here you can set Core Clock speed for GPU2, 0 is default clock
		{"id":1,"method":"device.set.core_delta","params":["3","0"]}, # Here you can set Core Clock speed for GPU3, 0 is default clock
		{"id":1,"method":"device.set.memory_delta","params":["0","0"]}, # Here you can set Memory Clock speed for GPU0, 0 is default clock
		{"id":1,"method":"device.set.memory_delta","params":["1","0"]}, # Here you can set Memory Clock speed for GPU1, 0 is default clock
		{"id":1,"method":"device.set.memory_delta","params":["2","0"]}, # Here you can set Memory Clock speed for GPU2, 0 is default clock 
		{"id":1,"method":"device.set.memory_delta","params":["3","0"]} # Here you can set Memory Clock speed for GPU3, 0 is default clock. NOTICE LAST LINE NO COMMA
	]},
	{"time":10,"commands":[
		{"id":1,"method":"worker.reset","params":["0"]}, # Not necessarily the necessary line but may remain in config
		{"id":1,"method":"worker.reset","params":["1"]}, # Not necessarily the necessary line but may remain in config
		{"id":1,"method":"worker.reset","params":["2"]}, # Not necessarily the necessary line but may remain in config
		{"id":1,"method":"worker.reset","params":["3"]} # Not necessarily the necessary line but may remain in config. NOTICE LAST LINE NO COMMA 
	]},	        
	{"time":20,"loop":20,"commands":[
		{"id":1,"method":"worker.print.speed","params":["0"]}, # This line will show you GPU0 hashrate every 20 seconds.  
		{"id":1,"method":"worker.print.speed","params":["1"]}, # This line will show you GPU1 hashrate every 20 seconds. 
		{"id":1,"method":"worker.print.speed","params":["2"]}, # This line will show you GPU2 hashrate every 20 seconds. 
		{"id":1,"method":"worker.print.speed","params":["3"]}, # This line will show you GPU3 hashrate every 20 seconds. 
		{"id":1,"method":"algorithm.print.speeds","params":["0"]} # This line will show you overall hashrate every 20 seconds. 
	]}, 
	{"event":"on_quit","commands":[
		{"id":1,"method":"device.set.tdp","params":["0","100"]}, # These remain lines will reset default values to all 4 GPU´s when you exit 
		{"id":1,"method":"device.set.tdp","params":["1","100"]}, # on excavator (CTRL+C) or miner will crash some reason. But When you start it again
		{"id":1,"method":"device.set.tdp","params":["2","100"]}, # lines above will tune back your OC settings. You can add more GPU and add remember add
		{"id":1,"method":"device.set.tdp","params":["3","100"]}, # workes, TDP, Fan, Core and memory too. Next fifth GPU are GPU4 ["0","4"]}, because 
		{"id":1,"method":"device.set.fan.speed","params":["0","50"]}, # counting starts at 0 and so on... 
		{"id":1,"method":"device.set.fan.speed","params":["1","50"]}, # Only Excavator 1.4.4 and below will work with other pools than Nicehash.
		{"id":1,"method":"device.set.fan.speed","params":["2","50"]}, # You can change time how often program show speeds to you. 
		{"id":1,"method":"device.set.fan.speed","params":["3","50"]}, # In line {"time":20,"loop":20,"commands":[ change both 20 to wanted seconds
 		{"id":1,"method":"device.set.core_delta","params":["0","0"]}, # example 10 will print speeds per GPU´s and overall every 10 seconds.
		{"id":1,"method":"device.set.core_delta","params":["1","0"]}, # NOTICE !!! That every last line wont have comma, it will give BAD -JSON  
		{"id":1,"method":"device.set.core_delta","params":["2","0"]}, # at starting and wont start mining if there are comma at the end of last line.
		{"id":1,"method":"device.set.core_delta","params":["3","0"]},
		{"id":1,"method":"device.set.memory_delta","params":["0","0"]},
		{"id":1,"method":"device.set.memory_delta","params":["1","0"]},
		{"id":1,"method":"device.set.memory_delta","params":["2","0"]},
		{"id":1,"method":"device.set.memory_delta","params":["3","0"]}
	]}
	]

After you have launched excavator you can check status from browser too, just type address: http://127.0.0.1:38081/

Sorry for way too much long post and full of typos. English aint my native language.
Hopefully this will help.

1 Like
  1. was using ewbf when the freezing problem started. now trying nehq which is working for now. will swith to either dstm or excavator and see what happens,
  2. increased my vm to 32gb (i set initial to 32 and max to 64, should i change it?).
  3. running stock.
  4. sata, but i also connected 6pin cables to gpu directly.

thanks. really appreciate the effort. will give it a try.

on another subject, i was searching the web for cheap gpus and i stumbled upon some strangely priced gtx 1060 gpus on ebay. it’s priced below 100$, sellers are top rated and have 100k or more positive feedback. they claim it’s a customized, low consumption version of geforce 1060 (unbranded apparently). i contacted many of them to ask about mining performance, none had any idea how it will perform in mining, has anyone tried it? i figure even if it gives 150 sol/s, it’s still a good deal for such low price! you can find it on ebay easily.

if it is to good to be true, then it is… odds are their accounts have been hacked

Dont buy those super cheap GPU´s. Those might be “wish.com” 1060 GPU´s and actually those are GTX 950/960 just NVRAM flashed to shown up as 10XX GPU. Just dont waste you money, buy where you know what you get.

Check this

and this…

probably a bad riser or loose pci connection. My home pc had a loose x16 slot and crashed frequently. pulled that card and its rock solid now.

1 Like

thanks to everyone, apparently dougrun was right. i changed the pci slots for3 gpus and tightened them, and it’s been working fine after 20 hours. will add more ram soon.

1 Like