ZCash Stratum proxy (Increase earning up to 10%)

just now i switched 1st test RIG to proxy (ethos)

Hi all
We just releaded the version 1.0.5.

Change log :

  • Rejected/Invalid shares after network error : fixed
  • Robustness hacks
  • Minor cosmetics changes

Enjoy !

1 Like

How you can use this to mine to suprnova? I get authorization failed when putting my username as the wallet.

1 Like

Hi @anon92308673
I think it’ll work with this small trick :
In config.json change the following fields

  • "enable_worker_id": false
  • "wallet": < supernova login >
  • "proxy_name": < supernova worker name >
  • "password": < supernova worker password >

This is an “ugly hack” but it can work (not tested yet).

1 Like

Proxy authorized with pool and says work is being accepted but it’s not reflected pool side.

1 Like

Thanks for opening this to the public.

One thing I’m noticing is that there are clumps of duplicate shares. If you get one, you usually get 5-10. This is painful to see as you can imagine. Any fixes planned for this?

On the proxy it shows as duplicate shares, on the miner it shows as rejected.

If this continues it will nullify using a proxy in the first place. Just want to make sure this is on your radar.

Also, a question: Have you tested this at larger scales? I’m using about 15 rigs x ~12 cards each and for the most part it’s working, but I haven’t noticed that much of a Sol increase, maybe because I already have a fast connection. Actually, my Sol/s has dropped a bit, but I’ll be monitoring.

Edit: What is odd is that if I remove some of these common workers with “rejected duplicate shares” other rigs that weren’t having problems start to have problems.

1 Like

Ok we need to investigate on this deeper… will look for a proper supernova integration later.

1 Like

Mmmm…, this look like the typic “difficulty sizing” issue : you are sending multiple solutions for an “already accepted share” (because the proxy act like an unique miner and all your workers mine the same “share”). So the pool tag the other works like “duplicate shares” and reject them…
So basically this is a “pool issue” : the pool is not able to scale the work difficulty proportionally to your aggregated hashrate… You can perhaps use a particular port (harder / ajustable hashrate) or set it yourself (sometimes through the client ‘password’ param, like flypool.org)

What is the pool you use ?

1 Like

I’m using Flypool at the moment, with fallbacks on other pools.

What settings would you suggest? Do you suggest using nanopool or some other pool with better worker/name support?

Looks like I’ll just have to test with a different difficulty level.

1 Like

Yep, you can try to change the flypool share difficulty changing the ‘password’ value or try to switch your farm to nanopool. Feel free to post back your tries/results :wink:


Flypool usual bug :ant: rejected shares dificulty error after they tried to raised shares difficulty It doesn’t work. That’s why I’m using nanopool so far so good nicely setup pool :slight_smile:

1 Like

Works perfect with dwarfpool and nanopool as I made couple of tests. Flypool rejecting shares seems some pool setup issue after they tried to raise shares dificulty- Flypool

1 Like

I was thinking of testing this, but i dont know if i need it really.
If i already have a config file saying it will use stratum for the rigs, why would i need this?

This is basicly just letting me to point my rigs all to this proxy that has the same settings my config has?

So for flypool adding 32000 or 64000 on the password field of config.json will fix the problem ?

Yep, if flypool adjust the difficulty properly it should be ok. Not tried, we use nanopool.

1 Like

Because, each worker of your farm is mining it’s own share instead of aggregating hashrate power on an uniq work using a proxy.
Confer this post for more detail :


I tested it. no luck. Flypool sends higher difficulty jobs. but still get the error duplicate work

:frowning: You can try to switch on nanopool or dwarf…
Did you try to disable the option “enable_worker_id” ?

Seems i cant get it to run on Raspberry PI 3 latest.
Getting this error.

olSocket = tls.connect(this.current_pool.port, this.current_pool.host, () => {
SyntaxError: Unexpected token )
at Module._compile (module.js:439:25)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/home/pi/zecproxy/proxy.js:2:18)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)

What im a missing or need to install?
Please help :slight_smile:

@BarbieAction Check the setup of config.json something is wrong maybe you made a unnecessary space between “” and so on.