Zcash4win BETA is out!

  program crashes there with the error above in the screen shot

So far I've tried
- Re downloading the proving key
- uninstall/reinstall of zcashwin
- tested firewall
- deleted old zcash.conf and re-ran first-time.bat
- deleted last block in case it was corrupt (restored it now)

ok, let's try launching it in a terminal window....start up PowerShell, and then run this command in it:

C:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

That'll startup zcashd in the PowerShell window in text mode, and it'll show block height, etc while it syncs.

Thanks for helping BTW :thumbsup:

It appears to not be doing anything, no new blocks being downloaded etc

that assertion failed message is not a good thing...what exact version of windows are you on? 7, 8, 10..... 32 or 64 bit

windows 10 64bit, though it was working fine for the last 2 weeks

I hate to recommend it, but have you tried re-syncing the blockchain all the way from scratch? (and if you do, run it from the command line as above until it gets caught up)

You can leave the *.log files and wallet.dat in place of course

ok doing a full re-sync now and it is running, cheers

Hi radius, one question please..
I have sent a 0.1 transaction from my z address holding 0.15 to another t addres..

In the transaction list, I can see the remaining 0.05 coming IN my z address. But I don't see the 0.1 going OUT to the T address.
However, the money arrived ok to the destination and in the blockchain explorer everything seems ok.

Is it normal behaviour of the wallet not showing the outgoing Z to T transactions?

Yes that's normal, nobody can see who sent it, not even you, when it's from
a z address.

Just to let you know, deleting and redownloading the block chain fixed this error. Cheers!

1 Like

Awesome, glad that fixed it!

Hello,

I juste started to use Zcash4win. When i see screenshot on internet about this tool, i see balance number like 0.00001 but in my tool i have 0.00 number (i guess i need at least 0.01 to see something ?). Is it something that i can tweak with command line ?

Thanks in adv for your reply.

you have to buy or mine zcash for the balance number to go up! :slight_smile:

Hello Radix,

I’m actually minning :slight_smile: That’s why i ask ^^ Still 0,00 balance

pool mining with GPU mining software or solo mining with zcashd?

because if you're solo mining the difficulty is so high you'll probably never win a block!

I use gpu (a bit less 200 h/s) and flypool so why my balance is still 0.00 ? Or maybe pool have minimum number to pay out ?

i dunno, you need to put an address from your zcash4win wallet into their system and payout, I don't know if that is manual or triggered by some threshold you set or what

Hello radix42, i was getting this error:

"A general unexpected critical error has occurred: couldn't connect to server: EOF reached (code 1) (make sure server is running and you are connecting to the correct rpc port) see the console output for more detailed error information"

Then i followed the instructions from here and deleted everything from %appdata%/zcash aside from wallet.dat and peers.dat. Now the wallet is working again and re-synchronizing itself.

But i used to have 0.04 on my balance, and now it shows 0.00, is that normal? should i wait till the blockchain is 100% complete? Thanks in advance.